Introducing Acumatica Cloud ERP: 2026R1
Get inspired and gain all the knowledge you need
Recently active
Hello Community,I am facing an issue related to creating a POOrder from a Service Order using the standard POCreate process screen.Scenario:Service Order Type: InternalFor this type, the Customer field is not mandatory by design.The requirement is to create a POOrder from such a Service Order.Problem:When attempting to create the POOrder via the POCreate screen, the system throws an error indicating that the Customer field in the Service Order is required.In standard functionality, the required validation for the Customer field is removed dynamically in RowSelected depending on the Service Order Type. However, when the Service Order is updated from the POOrder creation process, RowSelected does not appear to be triggered. As a result, the Customer field remains required and the validation error is raised.Additionally, I noticed that the Service Order is being overwritten during the attempt to save the POOrder, which seems to reapply the required attribute logic and leads to the validat
I want to create a PDF from a report in code and then send it to print. How can I do it?
We recently implemented using a weight scale and connected to the device hub and we are now noticing the scale is creating 3-6X the ERP transactions in the database. The user is simply putting box on top of scale and selecting “capture weight” then removing the box but Acumatica is seeing this as 5X the transactions instead of 1 time. Anyone else going through this dilema? We are seeing the SCALE try to poll every two seconds in some cases. Thanks,Nirav S.
I have a new customer based in Canada and we need a FastTrack Snapshot but with Canadian Localization, I attempted to restore a regular FT Distribution Snapshot, but everything was in USD and no matter how much I deleted I couldn’t change the base currency. Can anyone provide a snapshot for a Canadian localization?
We recently received a Purchase Order. It was split in receipt due to one container coming in November and the other in January. The first receipt for the items that were received pushed through correctly. Now the second receipt that we received today is not showing up correctly in our Inventory storage details. we have receipted the remainder of the soccer ball and have pushed the Bill - on hold as you can see below. However, the soccer balls received in the second and third receipt are showing in QTY available and not on QTY on hand. Which it should show on both columns. This is not allowing us to push any sales orders through to shipment because it shows that there is 0 in inventory. Please help.
Is is possible to link SO to an already existing PO? if so then what’s the process
Hello dear Acumatica community,we want to trigger automatic (email) notifications as soon as a responsible person has been assigned to a task.Currently I tried to solve this via the following business event (in German)Unfortunately, it is not possible to query the direct input screen for tasks (cr306020), nor the task overview screen (ep404000) for business events.Therefore I tried to find a solution via the general query "Tasks" (GI000024); namely this can be queried for business events. The problem with this query is that it does not trigger the business event in the default.After research in existing threads here in the community I found out that in the general query the conditions should be deleted to allow an error free triggering of the business event.But then the problem is that the query "Tasks" (GI000024) queries the activities in general. So if you remove the condition that only tasks should be displayed, then also mails, remarks, etc. will be displayed. So the First problem
It's great that we have such a vibrant Acumatica community to get quick answers to questions and gain product knowledge! We have very active members jumping in to help others out all the time. The goal of the community is to respond to every member’s question so that no one goes away "empty handed".Connect, Learn, Share Acumatica Community Webinar - Coffee & Code - Coffee & Code: Acuminator Version 4 - February 20, 2026 We hope you had a great time at Summit. There were lots of exciting new products announced and I can’t wait to get my hands on them. To help you out, we have a new version of Acuminator that was released, and @snikomarov36 will help highlight key changes, new features, and enhancements in our first Coffee & Code of 2026!RSVP HERE Congratulations to our 2026 Acumatica MVPs!The Acumatica Community is filled with customers, partners, and creators who are just as passionate about ensuring our ecosystem thrives as we are. Our Community members go the extra mile
Hello, we are wondering if there is a way to restrict time entered through time activities to only be entered in 6-minute increments or to round any time that is not entered in 6-minute increments to the nearest multiple of 6. Based on the clients we serve; this is the required way time must be tracked.
Good day. When Importing fixed assets I get the error “Value cannot be null. Parameter name: bookID”. Can someone guide what to check to get a successful import.
Hello, I am attempting to set up Acumatica such that outbound emails are automatically processed (that is, I want them sent out every minutes). I have attempted to set up Automation Schedules both for the Emails Pending Processing Screen (SM.70.00.00) and Send and Receive Emails (SM.70.00.10). However, the emails are “stuck” in the Pending Process phase on SM.70.00.00 (manually processing them works just fine). I have a few questions regarding this: First, my understanding is that this is achieved through setting up an “Automation Schedule”, correct? Are there any other ways to achieve this? If so, which screen should the schedule be set up on, SM.70.00.00, SM.70.00.10 or both? Lastly, and the real prompt for my question, neither of the schedules I set up for SM.70.00.00 or SM.70.00.10 are firing (per SM205030). There are no errors, just no “last executed” values. The schedules are active, were set to “start” in the past (6/27/2021 and 6/28/2021), are a “Daily’ Schedule Type with an E
When we build Sales Quote our Freight has to be included on a line item and the taxes are one amount. Then when we convert it to a sales order the tax amount changes. Same address and same tax area for sales quote and sales order. Can you elaborate on why the taxes change? Is there a solution to fix this?
I build this GI like last year. So it was this year I found out that when I multiply AvgCost * QtyOnHand some of the results are off by cents. this is my results
Hey all One of the things we do to maintain our customer base is have our customization send the customer’s Acumatica version back to the office so we can track where everyone is. Does anyone know how to retrieve the site’s patch status in code? It’s not in the version table, but i figure someone her might know.Thanks!
Hi ,When I try to create an expense claim, it does not automatically pick up the description for the selected expense item. Do you know why this might be happening?
Hello Community,We have faced one unique problem where our punch out creates cross references for all the NON-STOCK items from PUNCHOUT orders. Recently one of our customer reported that one or more items have the same manufacturer part# but different UOM making Acumatica cross reference reject the alternate item entry. After researching we found that Acumatica cannot accept alternate ID with multiple UOM for the same manufacture item from the vendor.Have you faced similar issue with your PUNCHOUT or using alternate IDs and what solution have you implemented? By the way this PUNCHOUT feature is a native Acumatica customization developed by our team but we saw this problem as common to everyone who uses alternateID for their cross reference.Any feedback or solution on this will be greatly appreciated.Vivek Vemunoorivivek@xtramilesoft.com
Has anyone customized a GI to create an export that can be sent in Excel to LCP Tracker for Certified Payroll?
I have added custom fields (UsrInDocType and UsrInRefNbr) in FSAppointmentDet to link to INRegister. When I try to delete the related INRegister from a button on FSAppointment using INIssueEntry, I get the following error:"Cannot mark the record as updated because another record with the same key exists in the cache."
Hello, I am receiving cash from customers as bank transfers and at that point, I am unable to identify the customer who made the payment. I am required to record the payment for the reconciliation purposes on the same period and on a later date or period, I am required to allocate that payment against the correct customer. Is there any way that I can handle this scenario with Acumatica by maintaining the original payment, allocation and same payment reference?Thank You
I have an e-mail that triggers off a business event that tracks when a project is switched to Active status. I’m using this phrase in the Email Template “To:” line ((PMProject_ownerID!Email)) but it is not picking up the Project Manager we have selected as the OwnerID on the Projects (PM301000) screen. When I use this phrase in the body of the tempolate: ((PMProject_ownerID_description)) I DO get the correct first and last name of the project manager. But even using this phrase: ((PMProject_ownerID_Email)) I still can’t pull the E-mail into the “To:” line. Do I just have the wrong syntax when trying to pull the Email address into the “To:” line??
I’m using the following version 2025 R2 and Build 25.200.0248. What I have to do is to override the character limit of a PXDBLocalizableString field from another DAC but I keep getting errors. Tried doing it the normal way as a DAC MergeMethod.Merge/Replace but I keep getting a Json de-serialization error. It does work, the DB column is set to the characters limit too but there is an error I’m getting when I try opening the Sales/Purchase Orders which error I think is coming from one of our customizations
I have spent a lot of time searching for a solution to this, but I’m stuck. Microsoft’s habit of continually changing things doesn’t help any of us. I’ve been working with MS Graph for a lot of years, and it never ceases to frustrate me.I am trying to configure email in Acumatica using Microsoft Office 365. I followed the steps in the documentation, and it works perfectly when I’m sending from the user I’m logged in as.My struggle is coming from trying to send from another mailbox. I’ve tried both shared and licensed mailboxes, and I cannot get either to work.When I attempt to send an email from the Shared mailbox, this message is returned: The mail send has failed. 535-5.7.139 Authentication unsuccessful, SmtpClientAuthentication is disabled for the Tenant. Visit https://aka.ms/smtp_auth_disabled for more information.When I attempt to send an email from the Licensed mailbox, this message is returned:The email cannot be sent because the account you signed in with does not have permiss
Hi, I want to check if a particular customization project is installed to run a specific piece of code in my project, how to do that? When i look at the customization projects screen the DAC doesn’t have IsPublished in DB, in the table i only see IsWorking column.
Hi all,We have an SO type RP (Return from Projects) that should only increase quantity and have zero cost. However, one SO (completed 1 year ago) was posted with inventory cost by mistake.Our items use the Average Cost method and are still in stock.What is the safest way to fix the wrong cost impact from this SO without affecting inventory valuation or accounting incorrectly?Thank you!
I’m trying to build a GI report based on INItemSiteHistDay, the end balance of in inventory after a transaction is considered as on hand quantity in the location. A date filter has been added to know a ending balance on the specified date, I have added a condition where INItemSiteHistDay.SDate is less than or equal to a specified date in the filter. The problem is that the report is showing all transactions before the date as shown below.Is there a way to show only the last transaction as on or before the date specified in the filter?
Already have an account? Login
No account yet? Create an account
Enter your E-mail address. We'll send you an e-mail with instructions to reset your password.