ShipEngine ShipVia not working after upgrade from 2019R1 to 2021R1

  • 4 January 2022
  • 2 replies

Userlevel 4


When my company went live with Acumatica in 2019 we were given access to a preview release of the carrier integration for ShipEngine.  Last week upgraded to 2021 R1 (v21.117.0037) which includes this feature out of the box.  Before the upgrade I unpublished all customizations and did not republish the early release version we had been using.  

Before this upgrade everything was working for us as expected between Acumatica and ShipEngine.

After upgrading to 21R1 I had to modify our carriers to use our ShipEngine Account ID instead of the API Token that the preview release required.  After that change the Test Connection button on each carrier reports success.  However, when I edit a ShipVia based on one of these carriers the service method selector no longer loads in any of the services tied to our account.

Due to this configuration issue, we are not able to successfully refresh rates or shop for rates from sales orders.  We are able to create shipments successfully with update 17, so I do not think this known issue applies to us. With that said do have a customization that overrides the CreateShipment method in SOShipmentEntry.

I looked in the bin folder for our site and I do not see any old copies of the DLLs from the preview version.  The same goes for the Customization Validation folder.

In the case of looking up rates and confirming shipments we’re seeing this error in the trace output:

SO Error: Carrier Service returned error. :Value cannot be null.
Parameter name: method


The stack trace is

Parameter name: method

   at PX.Objects.SO.SOShipmentEntry.ShipPackages(SOShipment shiporder)
   at PX.Objects.SO.SOShipmentEntry.PackageDetail.ShipPackages(SOShipment shiporder, Action`1 baseMethod)
   at PX.Objects.SO.SOShipmentEntry.<>c__DisplayClass52_0.b__0()
   at PX.Data.PXLongOperation.<>c__DisplayClass17_0.b__0()


Has anyone else run into this issue after upgrading to 2021 R1?  Is there a way to correct this problem?

I have some screenshots I can share.  I’ll attach them to comments to keep this message under the max size.


Best answer by PorchlightZach 4 January 2022, 19:50

View original

2 replies

Userlevel 4
Carrier Test Connection outcome
No service methods show up
Shipment Confirmation error


Userlevel 4

Well this was a quick resolution, I should I have tried this ealier.  Prior to posting my question I had already tried creating a new ShipVia on the old carriers to see if that made a difference (it did not).  I thought because the test connection button worked that meant carriers were fine. 

After posting I decided to create an entirely new carrier for UPS and a new UPS Ground ShipVia based on that Carrier.  After doing that the service method selector loads properly and shipments can be confirmed.


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved