Solved

Kit Assembly not working after Upgrade to 22R2 for certain items. Was working in Upgrade Sandbox

  • 22 March 2023
  • 7 replies
  • 148 views

Userlevel 5
Badge +1

Hi All,

 

We are experiencing some odd behavior and before opening a Support case, I wanted to see if anyone has experienced something similar.

A few items are blanking out the whole Kit Assembly Transaction once added.

The items are active, are marked as a Kit and have an active Kit Specification Record.

Blanked out

Example below with another item that works:

Any thoughts on why a few items would error out like that?

icon

Best answer by Hannah Barnes 22 March 2023, 21:24

View original

7 replies

Userlevel 5
Badge +4

Hi @krausef77 ,

There is a similar known issue being investigated right now.

In the known issue the main symptom is that this happens when a UOM conversion is changed or deleted on the Inventory item.

The issue is still being investigated.

 

Userlevel 5
Badge +1

Hi @krausef77 ,

There is a similar known issue being investigated right now.

In the known issue the main symptom is that this happens when a UOM conversion is changed or deleted on the Inventory item.

The issue is still being investigated.

 

Hi Hannah,

Thank you for the insight. Would changing the Unit of Measure to be divisible or not into this category?

Userlevel 5
Badge +4

Hi @krausef77 ,

That has not been determined yet in the investigation.
The only thing they know is that it sometimes happens if a conversion has been deleted.

If it’s divisible or not has not been found to be a factor yet.

Userlevel 5
Badge +1

Hi @krausef77 ,

That has not been determined yet in the investigation.
The only thing they know is that it sometimes happens if a conversion has been deleted.

If it’s divisible or not has not been found to be a factor yet.

After analyzing the Items it is happening for, it seems to be the factor causing this for us.

I will create a Support ticket as well, yet I hope this helps to further accelerate the investigation.

Is there a known workaround at this point?

Userlevel 5
Badge +4

Ah, I found more info, and yes, it looks like the UOM conversion just needs to be added to the Stock Items screen for the component:

Cause:

The Kit Specification for the corresponding kit has a stock item component with UOM not being setup for the corresponding inventory item:

image2022-3-26%2017%3A48%3A51.png?version=1&modificationDate=1648306132503&api=v2

There is no PK UOM in the Stock Items screen for the stock item corresponding to the kit component:

image2022-3-26%2017%3A53%3A3.png?version=1&modificationDate=1648306386207&api=v2

 

Userlevel 5
Badge +1

Ah, I found more info, and yes, it looks like the UOM conversion just needs to be added to the Stock Items screen for the component:

Cause:

The Kit Specification for the corresponding kit has a stock item component with UOM not being setup for the corresponding inventory item:

image2022-3-26%2017%3A48%3A51.png?version=1&modificationDate=1648306132503&api=v2

There is no PK UOM in the Stock Items screen for the stock item corresponding to the kit component:

image2022-3-26%2017%3A53%3A3.png?version=1&modificationDate=1648306386207&api=v2

 

Unfortunately, I cannot see the Screenshots that were attached, but it sounds helpful!

Userlevel 5
Badge +4

Oh for heavens’s sake. :)
So basically, there is a UOM configured on the Stock Components tab of the Kit Specification screen.
That UOM is not on the Component Item’s Conversion on the Stock Items screen.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved