Solved

Impossible to add more new field on DAC CT Contract with script

  • 6 February 2023
  • 3 replies
  • 43 views

Hey !

 

Since fews days, system doesn’t allow me to add any new field on the CT Contract DAC.

During validation, compilation is running an error : ‘Column name invalid’.

I tried to use a shorter name ,try to unpublished all and to republished but same result.

 

I can add  any field on other DAC (Baccoutn, etc) except this one. 

 

 

Have you ever face the same error ? 

 

Thank for any help ! :)

 

Cecile

icon

Best answer by gprice27 7 February 2023, 16:38

View original

3 replies

Userlevel 7
Badge +5

do you have original English error message? 

 

Userlevel 5
Badge +1

I am not sure, but maybe add this line to you DAC extension:

 

public static bool IsActive() => true;

Userlevel 3
Badge

Check your Database Script - and make sure the new field you added there has the same name as the declaration in the DAC extension

This error typically means that Acumatica cannot find the actual field in the Database table.

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved