Solved

24R1 - Shopify/BigCommerce Store configuration Results in "Index was outside the bounds of the array" error


Userlevel 1

Hi Team,

We setup an instance of 24R1 (build 24.104.0008) and trying to configure Shopify store.

But after providing configuration details when we are clicking save button, we are getting an error like: “Index was outside the bounds of the array”. Please find below screenshot for reference.

Can you please review and suggest the possible root cause and resolution for the same.

 

Thank you in advance!

icon

Best answer by KarthikGajendran 21 May 2024, 22:06

View original

4 replies

Userlevel 7
Badge +2

@arthia98 Can you please check this page? This is a known issue which will be fixed in the future versions. 

 

Userlevel 1

Hi @KarthikGajendran , We tried the solution to configure Shopify store, but unable to resolve, getting the same error “Index was outside the bounds of the array” , attached the screenshots for reference, added “LazyCachesEnabled” key in appSettings in webconfig file

 

Userlevel 5
Badge +1

Take out the space after LazyCacheEnabled. I fell into the same trap.

Userlevel 1

Thank you @KarthikGajendran for the solution 

Yes, It worked after removing the space, Thank you for your help @ejmillar 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved