Solved

Subreport only pulling data if data at Main report meets parameters.

  • 21 June 2022
  • 1 reply
  • 135 views

The report is only pulling data utilizing the main report parameters.  As long as there is data within the parameters of the main report it will print the main report and will then print the data from the subreport that is within the same parameters. If nothing prints in the main document due to the parameters nothing prints from the subaccount even though there is data that should print. What am I missing?

icon

Best answer by hkabiri 21 June 2022, 18:58

View original

1 reply

Userlevel 6
Badge +5

@ptingle10  You need to run the sub-report separately to verify and pass parameter that you meant to pass when running it from the main report. You mapped the sub-report parameters on the settings on the main report. If the results are the same then something related to what is being passed as parameter value. But if you get data when running it separately should check on settings on the section where sub-report is being added.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved