Question

Runtime on Reports too long or do not run at all

  • 1 February 2022
  • 11 replies
  • 294 views

Userlevel 1
Badge

We are having problem with reports not loading.  The spinning wheel just spins.  If the report finally pops up it take over 3 minutes.  Most of the time the report never loads.  This issue is effecting financial statements and generating AR invoices. 

 

My IT department has restarted the server and that does not help.  We can run Acumatica directly from the server and the reports work just fine, it appear to be only effecting the workstations. 

 

We have reached out to our Acumatica partner as well.  If anyone has ran into this and can point us in the right direct, it would be greatly appreciated. 


11 replies

Userlevel 7
Badge +16

I know I have seen this before and depending how big the data base is, that could be causing the issue. 

Try looking at the system health monitor. 

This was happening to me as well. We had to have our Acumatica independent seller go in to fix this for us. Turn around time was less than a day, so I would assume it’s a pretty easy fix.

Userlevel 1
Badge

System monitor looks fine, though I do not know exactly what I’m looking for in there. 

#cernst84 - Who is your Acumatica independent seller?  Our partner has no idea how to fix this issue.

Userlevel 3
Badge

Hi @lzettel , I’m assuming the server specs requirements have all been met. If it’s just certain forms and not all reports, I would open up the report designer (if not familiar, I would contact your partner for help) for each report that is having trouble loading, go to Files--> build schema and take a look at the “Relationship” tab for each report. There could be an issue with the joins on one of your tables. We have seen this in the past were we did not have a strong enough relationship between two of the tables being used on the report and the system is trying to sort through a large number of records to try to generate the report. 

Userlevel 1
Badge

@etrojan73  Hello - It is all my reports including arm reports.  I can’t even print an AR invoice.  All the basic financial reports like cash analysis, balance sheet, and even trial balance are not working in a timely manner. 

Userlevel 3
Badge

@lzettel I assume the workstations have adobe reader installed? That would be another thing I would check. 

Userlevel 1
Badge

@etrojan73 - Yes, I have Adobe Pro installed. I’ve had my IT department remove the Adobe update and there were no changes to the report run time.  There were also some windows and office updates around the same time frame.  Unfortunately, there are too many window/office updates to remove one at a time and rerun the reports after each one. 

 

Our partner has escalated a ticket with Acumatica.

Userlevel 3
Badge

@lzettel I see. Sorry, we couldn’t come up with a resolution but it sounds like you are in good hands with your partner. Please let us know what Acumatica support determines as the issue. This could be helpful to someone else down the road who encounters a similar issue. 

 

Thanks and have a great week. 

 

Eric 

Userlevel 7
Badge

Hi @lzettel were you able to resolve your issue? Thank you!

Userlevel 1
Badge

Hi @Chris Hackett, no this issue has not been resolved yet. The last I heard was something about uninstalling the windows update, but my IT department is not willing to do that because the windows updates were all security updates.   

Userlevel 3
Badge

Hi @lzettel I guess this issued is fixed . Could you please let me know what fixed this issue ?

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved