Question

Issue faced after upgrade


Userlevel 2
Badge +1

Hello Friends 

We have an Acumatica 2021R1 instance with build 21.116 

Using the Apply Updates screen, we are trying to upgrade it to 21.119 build.  Right after the upgrade process is completed, we are seeing this error message

Could not load file or assembly 'PX.Telemetry.Adapter, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. The system cannot find the file specified.

 

Could you please assist if there is anything that I am missing here on the upgrade or if anything needs to be done before initiating the upgrade?  

 

Thanks

Saikumar C

 


11 replies

Having the same problem.  Any solutions?

Userlevel 5
Badge +1

Hi @jbischoff43

Any other symptoms besides this message?  

 

When I refresh the page, it brings me to a login screen with the red warning, “Last Update was not successful”, and when I go to the Apply Updates page, the update has not been applied.

I am attempting to upgrade from 21.204.0055 to 21.205.0063, and I’ve also attempted 21.209.0034.  Same error both times.

I was able to successfully upgrade using the 21.209.0034 Acumatica ERP Configuration Wizard, but I cannot do it from within Acumatica itself.

I just tried to use the in-system update to 21.209.0034 from 21.206.0024.  I have the same error (Could not load file or assembly 'PX.Telemetry.Adapter’) and I confirmed that dll doesn’t exist in the bin folder.  It IS in the bin folder in the site backup the upgrade created.  I don’t want to copy in the old version as I don’t know if it was changed.  

What do we do?  I’m guessing uninstall and install fresh to get that version? 

@bdimes, I downloaded the Acumatica ERP 2021 R2 Update 9 package from here: 

https://community.acumatica.com/supported-releases-67/acumatica-2021-r2-update-9-build-21-209-0034-8512

 

Installing this will automatically uninstall any previous version you have installed. 

After installation, I ran the app and went to Perform Application Maintenance, selected my instance, and clicked Upgrade.  This method was successful for me.

Userlevel 2
Badge +1

Thanks @jbischoff43   

This method has worked for me too but executing the upgrade from inside of Acumatica still continues to give the same message.   

Not sure on what is a good solution to avoid that.    

 

 

@Sai Chettiar, I was able to upgrade from 21.209.0034 to 21.211.0033 from within Acumatica, so the issue appears to have been resolved at least some of the time.

Userlevel 2
Badge +1

Thats good to know @jbischoff43  since yesterday I worked on an upgrade from 21.119 to 21.122 and experienced the same issue.  I will check on another instance that I have with 21 R2 and share my experience from that one too.  

 

 

Userlevel 7
Badge

Hi  @Sai Chettiar were you ever able to resolve your issue? Thank you

Had this issue upgrading from 21.203.0030 to 21.215.0016. 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved