Build errors on training project. (Re-submitted with enlarged screen shot)

  • 2 November 2020
  • 41 replies
  • 822 views

Userlevel 1
Badge

Are references pointing to wrong path? What is the fix?

 


41 replies

Userlevel 1
Badge

Thank you Naveen. I have completed the 4 steps above on UpdateTCourses. I still get the the 79 Build errors. Please see below screen shots of Web.config file. Can you advise?

 

Userlevel 7
Badge +12

Hi @dherr70,

 

Have you created this website through Acumatica ERP Configuration? attached screenshot for your reference.

I’m assuming that you have created this website/instance in Visual Studio itself. 

 

Userlevel 1
Badge

Thank you Naveen,

I did create it through Acumatica ERP Configuration. I followed the instructions in the T190 Training Guide, pages 9 & 10, which I am attaching here. I see that the guide was revised on 11/10/20, however this portion looks the same to me (except for changed page numbers). Can you advise further?

 

 

Userlevel 7
Badge +9

@dherr70 the website that I see in your screenshot (Solutions Explorer) section doesn’t look like the usual Acumatica Web Site structure. The web.config file is also not the standard Acumatica web.config. This will definitely not build or run.

Did you create the Visual Studio solution yourself, or did you open a .sln file that already had the customization project and the website already included?

For your reference, here’s how an Acumatica web site usually looks inside Visual Studio:

 

Userlevel 1
Badge

Thank you Gabriel, not sure if you saw my response to NaveenB74..

I created it through Acumatica ERP Configuration. I followed the instructions in the T190 Training Guide, pages 9 & 10, which I am attaching here. I see that the guide was revised on 11/10/20, however this portion looks the same to me (except for changed page numbers). Can you advise further?

Userlevel 7
Badge +9

@dherr70 if you’re free right now, please jump on a Zoom meeting for me, I think I can get this solved for you relatively quickly :) 

Link: https://us02web.zoom.us/j/5146534118

Userlevel 7
Badge +9

Update: just had a quick Zoom call with @dherr70, everything is working now. I recorded part of our call in case it can be useful to others (unfortunately I forgot to start recording earlier)

 

Userlevel 1
Badge

Many thanks Gabriel!

-Dave

 

Userlevel 1
Badge

Hello Gabriel, thanks again for your great help the day, however even though my project will now build, I get the error below when trying to run it. Am I missing a step from what you had provided?

 

Userlevel 1
Badge

Also I cannot see where to access the video you had made, sorry!

 

Userlevel 7
Badge +9

A few things:

  • You need to be running Visual Studio in Administrator mode; the AcumaticaERP website is showing as unloaded in your screenshot because Visual Studio is not able to access it. Right click Visual Studio and select Run As Administrator when you want to build and debug web sites hosted in IIS
  • The startup project in your solution is the class library PhoneRepairShop_Code. A class library is not an executable and can’t be started. Right click the AcumaticaERP web site and set it at startup, or simply attach to w3wp.exe to debug the running instance (I always use the second option -- this is what we did in the video)

Visual Studio/ASP.NET training is outside the scope of the Acumatica developer training; I think it will be much easier for you if you go through the requirements outlined in the developer training guides:

 

 

The video is a few posts up in this thread; here is it again for your convenience:

 

Userlevel 1
Badge

Thank you Gabriel. Of course that worked. I recognize the Requirements page from the training manual, and admittedly some of these are at the outer edge of my skill set. (No doubt this was evident during our call!) My primary experience has been in the Business Basic / Providex world. I have been learning .NET in my spare time, and look forward to becoming an Acumatica expert. Thanks again for your time and your patience!

 

Userlevel 7
Badge +9

Fantastic @dherr70 -- you do seem to have a lot of perseverance, and that’s a great skill. The Acumatica framework is extremely powerful, but the learning curve can be steep at times. Good luck and I look forward to hearing about your progress in the near future 😊.

@Gabriel Michaud  Hi, i have similar issues.

 

it seems to me that the main error is “The file '/MasterPages/FormView.master' does not exist. ”

i figured that if i uncheck “Build Website as part of sulution” on “UpdateTCourses” it will only be a warning and not an error, is this the sulution? i am not comfortable doing it.

 

Thanks

Userlevel 7
Badge +9

@lbrailofsky29 that sounds like a different issue. You definitely need to keep “Build Website as part of solution” unchecked... 

@Gabriel Michaud when “Build Website as part of solution” is unchecked i still get 6 errors and the 97 warnings, example of error below.

“'Page_RS301000' does not contain a definition for 'Context' and no accessible extension method 'Context' accepting a first argument of type 'Page_RS301000' could be found (are you missing a using directive or an assembly reference?)“

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved