Question

UDF values not getting displayed

  • 16 November 2023
  • 6 replies
  • 57 views

Userlevel 3
Badge

Hello team,
I have added one UDF field in the projects form, but its values isn’t getting displayed in the report:

 


 

I also tried using the INNER JOIN between PMProject.AttributeAuthorize & AuthRepres.BAccountID; PMProject.AttributeAuthorize & AuthRepres.AcctName but it displays the same result as above.


6 replies

Badge +16

Hello,

Are you trying to add the name of the Authorized Representative to your report?  Are you trying to add the Project Approver to the report?

It seems to me that you want to use the Authorized Representative UDF in this join, if you want to show the name of the UDF employee on your report:

 

If you place the UDF on your report directly, from PMProject, is it populated? 

 

Laura

Userlevel 3
Badge

Hello,

Are you trying to add the name of the Authorized Representative to your report?  Are you trying to add the Project Approver to the report?

It seems to me that you want to use the Authorized Representative UDF in this join, if you want to show the name of the UDF employee on your report:

 

If you place the UDF on your report directly, from PMProject, is it populated? 

 

Laura

Hello @Laura02 ,
I am trying to display the Employee name based on the Employee ID selected on the UDF. I tried this now:
 

Same result

Then tried this:
 


 



Still the same result.


​​​

Userlevel 3
Badge

Hello @Laura02 ,
just to update you, I recently checked out the same joins in other report & is working fine. Now when I changed my parameters in the current report, the report displays the correct information:
 


I don’t know why it is not displaying the result when i try to add the parameter as Report.GetFieldSchema (‘PMProject.ContractCD’) and setting up the filter as PMProject.ContractCD Equals (parameter name)

So what t I did now is, I made the changes in the parameters as follows:
 


 

 

Userlevel 4
Badge +1

Hi,

Your attribute is using the “AcctCD” value and your joins are using the ID… could that be it?

Userlevel 3
Badge

Hello @Laura02 & @miguel80 ,

Just to update,

I just tried to copy the report into another instance and now the field doesn't display the record, whereas its working fine in the above instance (, screenshots), even the UDF are the same. Now wondering how is that possible.

Userlevel 7
Badge

Hi @Mondeddula Madhu Venkat Reddy were you able to find a solution? Thank you!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved