Solved

GI - DateAdd function not working on conditions

  • 29 June 2023
  • 1 reply
  • 157 views

Userlevel 4
Badge

Hello,

I am struggling to get the DateAdd function to work on my conditions. I am able to get it to work in the results grid and in the report designer but for some reason, it is not working on the conditions. Below are some screenshots.

Today = June 29th, 2023

Screenshot 1: Conditions

Screenshot 2: Result Grid

Screenshot 3: GI Results

Thank you,

KT

icon

Best answer by meganfriesen37 29 June 2023, 18:57

View original

1 reply

Userlevel 7
Badge +10

In your filters, try using LastModifiedDateTime >= @Today-1
 


This gets me everything I modified today.  I wasn’t in my demo environment yesterday, so I can’t see how/if it would display stuff from June 28 as well:
 


Alternately, it could be a time zone issue in terms of how things are displayed.  If you’ve got items that have a time/date stamp of last modified at 11 PM Pacific on June 29, that would be 1 AM June 30 Central time.  I’m not 100% sure whether the @today filter uses UTC or your system default time zone but there could be something up with that as well.
 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved