Smartsheet Integration Error

Userlevel 7
Badge +17

Hello Everyone,

I setup the Smartsheet Integration in Acumatica and connected with Smartsheet succesfully.

Then I created a project in Acumatica and when I’m trying to sync the project getting below error. Can you please help me with this?

And also, observed that “UsrSmartsheetContractID” field is NOT filling in Contract table.




20 replies

Userlevel 7
Badge +3

It looks like you have your project mapping configured correctly on Project Preferences. Many times this can lead to errors. I tested with the latest SalesDemo, customization SmartSheetIntegrationV23, and your configuration and everything worked bi-directionally.

Do you have any attributes that are required in Attributes tab of your project? 

Userlevel 7
Badge +17

Hi, @Doug Johnson  Thanks a lot for the response.

This the brand new instance, NO customizations published/Complete DEMO data with default Acumatica configuration. (Only AcumaticaSmartSheet Integration package published on the instance)

I do not any required attributes in the projects screen. Please find the screenshot for reference.



Userlevel 7
Badge +17

Hi, @Doug Johnson I have changed the duration in the Projects Preferences screen and populated that dates but, now we getting the below issue.


Userlevel 7
Badge +3

@Naveen B  I cannot reproduce with Acumatica 2020 R2 (20.202.0043) and SmartSheetIntegrationV23, but within Smartsheet there are dependency settings that could be causing the issue. I remember that in an earlier version of Smartsheet integration, I could not sync the end date because the duration and end dates might not be consistent.



Userlevel 7
Badge +17

Hi, @Doug Johnson  Thanks a lot for the response. 

Sure, I will check with the 20 R2 version and let you know.

Userlevel 7
Badge +17

Hi, @Doug Johnson,  We have installed 20 R2 (20.202.0043) version and published AcumaticaSmartsheet (downloaded from the below path) but we still seeing the same issue with new version also.  I’m I doing anything wrong with the mappings or Project/Project Template/Project Tasks creation? Could you please review and confirm.





Mapping Screen


Projects screen



Hi @Naveen B@Doug Johnson ,

I’m experiencing the same errors and found that field mapping in Projects Preferences plays a role. For your first error message, I replicated your setup and found that leaving the PREDECESSORS field blank stopped it from happening. For your second error message that I also cannot get past, I’ve tried mapping to different fields and none of them work.

I tested with 2020 R2 (20.211.0037) and I downloaded the ZIP file using the same link that you used.

@Doug Johnson you mentioned using customization SmartSheetIntegrationV23. I cannot find that version and wonder if you can share the link to download it. I’d like to use the identical setup as you and see if I can get your results.



Another reason why I believe field mapping is a little funky is I tried ‘Task Sheet’ in Projects Preferences. I started with all 6 fields. With each error, I tried a different Acumatica field. When nothing works, I left the field blank. I was down to 3 fields (Task Name, Due Date, Comments) when integration went through without errors.

Userlevel 7
Badge +3

@eric30 Sorry, that was a typo. SmartSheet Integration V2 is what I am using. We are working on a build that will support 2021 R1 and will post it to GitHub when it is ready.

Userlevel 7
Badge +17

Hi, @eric30  When I add only these 3 fields (Task Name, Due Date, Comments) in the mapping then the sync part is working fine and the moment when I add StartDate, EndDate and etc getting errors.

Do we have issues with integration?

@Naveen B. Dumbing down the fields to map is a way to generate the Smartsheet project. But that brings little satisfaction when you cannot synchronize updates back to Acumatica.

We have many sales prospects inquiring about project tracking, resource planning, and project management capabilities with Acumatica. We feel that this integration is a good start and has great potential but not ready. In our demos, we focus on Project Accounting but do not elaborate on this aspect and do not market Smartsheet Integration.

I wonder if anyone using the Construction Edition has positive result with Smartsheet integration or other ISV tools.

Userlevel 7
Badge +3

Dear Community:

The SmartSheet integration software on GitHub was updated 2 days ago.

The latest version works with 2021 R1. I was easily able to install and sync projects on my local instance. I have had some challenges with my AWS sites, but others have successfully installed it.


Userlevel 7
Badge +17

Hi, @Doug Johnson  Awesome :) and Thanks a lot for sharing this info.

We will install and test this out, and keep you posted on the results.

Hi, @Doug Johnson ,

I setup the new integration in 2021 R1 but am still running into issues. Here’s a summary of what I can and cannot accomplish:

  • Download from GitHub, publish ZIP, connect token are successful and same as before
  • For ‘Project Sheet’ mapping, I connected ‘Task Name’, ‘Start’, ‘Duration’, ‘Complete’, and ‘Comments’.
  • If I have ‘Start’, ‘End’, and ‘Duration’, I received an error.
  • If I mapped Approver to ‘Assigned to’, I received an error.
  • I tried mapping different fields to ‘Predescessors’ but received error for all of them.
  • I mapped ‘Status’. Since the default options in Smartsheet do not match the status in Acumatica, subsequent sync did not change task status.
  • I updated % Complete, Start Date, End Date, and Duration in Smartsheet but subsequent sync did not update project tasks.
  • The only field I was able to sync back is ‘Comments’ that I mapped to Task Description.

If you’re able to sync your project, can you help me figure out what I’m doing wrong?

Userlevel 2

In case anyone gets the following error when going to either “Project Preferences” or trying to access Projects screen PM3010PL after publishing Smartsheet integration, the fix is simple (at least in my case).

"We're sorry! An error has occurred while processing your request. A report has been generated for our technical staff to investigate the problem. Please try to repeat your request later. Thank you for understanding."

Reviewing the trace shows this:-

Error: | The type initializer for 'ListPMTaskAttribute' threw an exception.

The fix is to make sure you have a project and a task available when you publish the integration. Sounds obvious now of course but took me days to work out ...

Userlevel 7
Badge +17

Hi, @GrahamMartin  Yes, I got this issue too long back :( and don’t know the root cause for it.

Thanks a lot for sharing this info :) 

Userlevel 3

Hi @GrahamMartin, what you do mean that a Project and Task need to be “available”? I already have multiple projects and tasks assigned to those projects. The Projects module works fine without the Smartsheet customization but then I get the error you mentioned after I publish the customization.

Userlevel 2

​​​Hi  @cshaheen26

For me, I was getting the error no matter what I did until I created a project with a task and made them active before I published the customisation. As soon as I did that, the error went away. I haven’t tried all the other possible combinations of this but I do know that if I unpublished the customisation, deleted the project task and project (leaving me with an empty system again) and then re-published, the error came back - ergo my summation that the ListPMTaskAttribute could not handle a blank list and was thus throwing the exception.


As I say I didn’t try any of the other various possibilities, but your experience suggests something more is at play. I’m afraid I don’t have further answers :(


I was able to create the project and sync to smartsheet using the basic fields as mention about. However, upon updating the smartsheet, I am unable to sync back with Acumatica. The following error was thrown:

I am still using Acumatica 2020R2 (build 20.206.0011) with Smartsheet Integration V2. 

Anyone else encountered this problem and have a resolution for it?


Userlevel 4
Badge +1

We are using 2021 R1 and have the Smartsheet 2021 R1 integration installed. 

Still getting the error: 

End Dates on dependency enabled sheets cannot be created/updated.  Please update either the Duration of Start Date column. 

The only workaround that has worked is the same as @Naveen B - remove the mapping for End Date and Duration… 

From troubleshooting, it seems that there is conflict between Acumatica and Smartsheet regarding subtask dependency. Acumatica needs an End Date for the task in order to sync… Smartsheet won’t allow you to edit End Date or Duration for parent tasks (read-only).

I even tried unchecking “enable subtask dependency” in the project template task...


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved