Solved

Import scenario to skip existing customer record while doing insert operation

  • 12 January 2022
  • 8 replies
  • 258 views

I want to import the unique customer records using import scenario.

I  want to skip the existing records & insert only non existing records.

The record skip logic should be execute on “CustomerID”.

icon

Best answer by mikeschmitt81 12 January 2022, 16:01

View original

8 replies

Userlevel 7
Badge +12

@sysuser113  By default Acumatica, will look into the Keys (In this case it is Customer ID), if this value already existed in the system, process run and update the record if not exist Customer record will be created in the system. 

@Naveen B  Thanks for the reply.

Yes, Acumatica check the Key and if the record exist then it updates the record.

I don’t want to update the record instead of update it should skip the record.

Userlevel 1
Badge

@sysuser113  Review the Incremental sync type option - in the help text 

 

Userlevel 2

@mikeschmitt81    Have you been able to get this to work?  I just did some testing w a file that imports Stock Items.  I had ItemID 35802 in my source file. I imported it successfully.  I then opened my source file, left Item 35802 in there, and added a new line for item 35803. This is the scenario referenced in help “if after the initial import you need to periodically upload new data records that have appeared in the source.”  I saved the file and “upload new version” in the IS.  I ran the import scenario.  It gave an error on item 35802 that “An attempt was made to add a duplicate entry” on the Purchase Unit field -- this indicates it tried to import the previously-imported record and didn’t skip that one, as the help screen says it should have “for importing only some of the data from the source”. I tried sync type of Incremental - All Records as well as Incremental - New Only, and they both acted the same way, gave the same error on the existing item and imported the second, new item 35803.  If you’ve gotten this to work, I would love to understand your steps to a successful partial import.  Thank you!

Userlevel 4
Badge +1

On your stock item import, remove the checkbox for <ACTION: CANCEL> and see if it works, as well as the <LINE NUMBER> checkbox for the -1 value. 

 

Userlevel 2

@jeremyd45    I tried unchecking “<Action: cancel>” line; no luck, same error message about adding a duplicate entry.  There is no line for <LINE NUMBER> = -1 to uncheck in this type of IS (we’re creating a master record, not a detail line on an order), and even if there were, then no record would be inserted, which is what we’re trying to do -- only import/create new records, leave existing records alone.

Userlevel 4
Badge +1

Can you share your import scenario? That might help people troubleshoot. Thanks!

Userlevel 3
Badge

Is there a resolution to this?   I am trying to do something similar with Project Tasks.  I have tried to use target restrictions, but I have not figured out a way to not update existing records.

 

OK, I figured out something that works for me.  I set up a target restriction.  In my case I looked at the status of project task and told the system to only process records with a certain status.

I am wondering if for this topic if you set a target restriction to CustomerID is Empty which should only allow you to add new records. 

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved