Solved

"Activate Project" Option not working in Import Scenario

  • 16 May 2022
  • 8 replies
  • 314 views

Userlevel 7
Badge +10

We had an import scenario that worked in an older version of Acumatica that was used to import large volumes of projects into the system and automatically create and activate the projects.  In the older import scenario we used to force a “False” into the Hold field to trigger the activation.

With the upgrade to 2021R1 and the addition of the Workflow Automation, the old import no longer works as the Hold button is gone.

I have tried using both of the options below, but I get the same error on both of them.

Target Object Field/Action Name
Project Summary <Action: Activate Project> (Activate)
Project Summary <Action: Activate Project> (Activate@Action)

 

Error: Object reference no set to an instance of an object.

If I deactivate the line in my import scenario, the projects are created just fine, but they are “in planning.”  The error only comes when I try to activate them.  I’ve also tried updating the status field directly in the import scenario but that does nothing.

What do I need to add to my import scenario to get the projects to activate?

Thanks!

icon

Best answer by Naveen Boga 17 May 2022, 10:03

View original

8 replies

Badge +18

Hi,

Here is an import scenario that I created & used successfully last week to activate tasks and projects  in version 2022 R1.

 

Userlevel 7
Badge +10

This is what I am using and getting an error on:
 

I am creating projects from scratch (new projects).  The site is on version 21.119.0030

Megan

Badge +18

I usually import projects in multiple steps: Projects, tasks, then a separate import that only activates the tasks and projects. I hope it works for you too. If not, someone else will come along and post more ideas.

Userlevel 7
Badge +19

Hi @meganfriesen37  I just created a sample import scenario, where we can provide the Project ID to Active the TASKS and PROJECT. 

I have verified it and working as expected!! 

 

Here is the import scenario.

 

Userlevel 7
Badge +10

Hi Naveen,

I tried copying your scenario and have it linked to an excel provider with a list of projects...and I’m still getting the same error in Acumatcia 2021 R1 (21.119.0030) (screenshots below from 2021 R1). 

I tried this in 2022 R1 (22.103.0018) and it worked.

So obviously something is broken in the older version and has been fixed in a newer version.  I’ve run into a similar issue with another import scenario with the Action buttons in 2021 R1 not working as expected.

 

 

 

Userlevel 7
Badge +19

Hi @meganfriesen37  Yes, I have created that import scenario in the 22 R1 version, and the build [

22.104.0012] :) 

 

Let me check in 21 R1 and get back to you.

Userlevel 7
Badge +19

Hi @meganfriesen37  I have verified in the 21 R1 version and the same import scenario is working fine.

Please find the screenshots for reference.

 

 

Userlevel 7
Badge +10

I think there’s something funky going on in their specific environment, because we’re able to do it exactly as shown above in our demo environments.  We’ve done a workaround using a mass update option on a generic inquiry to select and activate selected projects.  It’s an extra step but it’s working for them.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved