When activated 2FA for a user and after login in web instance, I m not able to get the notification on registered mobile.

  • 4 March 2022
  • 6 replies

When activated 2FA for a user and after login in web instance,  I m not able to get the notification on registered mobile.


Best answer by dbushert 4 March 2022, 22:37

View original

6 replies

Userlevel 4

Have you tried deleting and reinstalling the Acumatica app on the phone?

I had a similar issue when upgrading my iPhone.  I had to remove the device from my user account and also fully delete and reinstall the app.  The migration from my old phone to new one copied my settings, but all my previous Acumatica 2FA quit working.



Several of our users had this issue, if I remember correctly the process to fix was as follows:

  1. Delete registered device from User profile page
  2. Generate Access Codes (print or save to PDF)
  3. Delete and reinstall Acumatica app on user’s phone
  4. Sign in to app, make sure correct tenant is selected
  5. Type access code from list into app
  6. Sign user in to Acumatica website and 2-factor should work again.  (May have to repeat this step using one of the generated codes from list instead, then log out and back in on the website to activate 2FA.)
Userlevel 4

I wish Acumatica had a way to migrate the 2FA to a new device.  We use 2FA to access all of our clients, and upgrading my phone required me to re-setup almost 50 Acumatica sites.


Userlevel 5
Badge +1


I followed these steps and it is still not sending the confirmation request to my mobile device.

Not sure what to do at this point… we can Generate Access Code from mobile device app, that works. But the push request to the mobile device would be much more convenient. Very disappointed it is not working.


Turn on Notifications is Checked Yes and Send Confirmation Push is Checked Yes.

Userlevel 5
Badge +1

@dbushert Update - this was a known issue and Acumatica fixed it. After updating to Build 23.207.0025 the push authorization to the Acumatica mobile app is now working. Cheers!


If anyone else is still having this issue - I recommend creating a support case with Acumatica to upgrade your site to at least build 23.204.0031 - this was the update that fixed the issue.

Userlevel 7

Thank you for sharing your update with the community @nathantrauscht!


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved