Solved

Data is absent error on Sales Order Line upload

  • 15 June 2023
  • 7 replies
  • 260 views

Userlevel 2
Badge

Wondering if anyone else encountered the error “Data is absent” during the Sales Order Line upload function? 2022R2

The client provided an excel workbook, and I added an upload tab as the first tab in the workbook for the upload data.

If I copy that upload data to an empty new workbook, it will upload, so I know my data is clean.

What settings on the excel workbook might be causing this error?  I have verified that the sheet and workbook is not protected. What else could it be? 

 

Any idea would be appreciated.  We have not seen this error before.

 

icon

Best answer by GBower 7 July 2023, 00:46

View original

7 replies

Userlevel 7
Badge +16

HI @TShoaff 

Have you tried exporting the actual grid from the Sales Order Details and putting the data on that then uploading?

Userlevel 2
Badge

Thanks Kandy for your reply.

Yes we have tried exporting the grid.  Support has suggested it is related to formatting or formulas.  It is a complicated workbook and I would prefer to keep the import sheet there for audit purposes, but it may not be possible.

Userlevel 2
Badge

 

The only method I found that works is to save the sheet as a CSV (comma delimited), it doesn’t save all the sheets in the workbook, however it is more efficient that copying to another workbook.

Userlevel 5
Badge +1

This sounds like the original excel spreadsheet has formula, lookups, etc.  When you copy to a new workbook are you just copying the data (as text)?  The upload will read the exact contents of the cell so if a formula exists, it will not recognize it.

Userlevel 2
Badge

Yes, the workbook the client uses has several sheets.  We are copying data from one sheet, to the front sheet for upload as Text/  Formulas on the other sheets must be interfering with the upload process in Acumatica.  

I found this thread via search after spending 30 minutes trying to fix the same issue.  While the above suggestions didn’t solve my issue, they did get me started down the path to a simple solution.  Hopefully, the following helps somebody in a similar position: 

Change from the standard Excel view to the “Show Formulas” view (“Formula” ribbon / “Show Formulas” button). 

I was absolutely positive there were no formulas on my upload sheet, but three were buried in data.  One was a manual edit to fix a rounding error (x+.01) and the others were my total at the bottom of the dr./cr. columns.

I suggest switching views and manually confirming there are no formulas.

Userlevel 3
Badge

I found the “Data is Absent” error as well.  In my case there was a series of blank lines after my initial data set.  Then, about 100 lines down there was a TOTAL line in the middle of the worksheet (well after my last upload record). 

The solution was to delete all blank rows after my last data record to the bottom of the worksheet and that fixed the problem.  Vexing but I made a note now so I won’t soon forget this small detail when creating an upload file.  Kind regards, Mike Lupro

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved