Solved

Workflow Customisation Problems

  • 28 November 2023
  • 2 replies
  • 72 views

Userlevel 3
Badge

Hi guys,

Hope you’re all doing well,

I have created a customisation to SO workflows and added a couple new statuses, Customer approved- triggered by pressing an action; In Production - triggered by creating production orders; Purchased - triggered by creating a purchase order.

The issue i am having is that the create production orders screen PO505000 does not show any lines in the customised status of Customer Approved but when in Open status it does show the lines marked for PO.

I have looked into the Data Access in PO505000 but couldn’t find anything, is there anything that I am missing/doing wrong?

Any advice would be greatly appreciated!!!

Aleks

icon

Best answer by darylbowman 28 November 2023, 22:12

View original

2 replies

Badge +10

From what I can tell, the reason it’s not showing with your custom statuses is because the data view bound to the detail rows is explicitly looking for certain statuses, of which your new ones are not a part.

I can’t determine where exactly this filtering happens, but my best guess is here:

 

If this were a processing screen controlled by workflow, I think it would be relatively easy to add your statuses as a valid processing state, but sadly, it’s not, and I’m afraid it would be rather complicated to add your statuses into the data view.

Userlevel 3
Badge

Thanks Daryl,

I think I will update my workflow to include the transition to ‘Open’ and PO’s will have to be made from there.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved