Solved

Business Event Firing but Not Sending Email

  • 13 November 2023
  • 9 replies
  • 118 views

Userlevel 1

Hoping someone can assist. I have created a business event to send Shipment Confirmations once the Status of the shipment has been triggered from Open to Confirmed. 
 

The Business Event is working as there is a history of them firing, but the emails are not being sent:
 

 

this is the Email Notification Template:

 

 

Ive read other questions on here and the answer has been in the To: Field.. but I need to send it to the overridden Shipping Contact Email and there is no options for that: “


If anyone can help me that would be much appreciated.
Cheers
Lara

icon

Best answer by Connor Morse 14 November 2023, 03:59

View original

9 replies

Userlevel 7
Badge +17

@Razza83  Have you tried with Shipment Screen (SO302000) instead of GI00055 in the Business Event?

Userlevel 7
Badge +12

Hi @Razza83 

Please share the XML, Email template and Business events for review,

 

Tips:

  1. Make sure all the Key fields are added in the Generic inquiry.
  2. Please add the GI conditions fields in the Business event Track fields

Instead of New field values, create a Generic inquiry and put a condition = Shipment status equal to confirmed.

Business event trigger by record inserted.

Please review 

Userlevel 1

Thanks guys, but none of these changes seem to be working.

Userlevel 5
Badge

Hi @Razza83 ,

Try adding the SOShippingContact table to your GI as seen below. Once added, add the SOShippingContact.Email to your results grid. You should then be able to add ((SOShippingContact_email)) as the “To: “ field.

 

** Although you may be using an older/different version where the tables/field might be different, hopefully the screenshot below can help you get the correct field brought into the GI and onto the email template. The difference on your version appears to need to use the SOShipmentContact table instead of SOShippingContact. So the “TO: “field may end up being ((SOShipmentContact_email)) or something similar.

 

Table Relation: SOShipment to SOShippingContact
GI Results Grid Field
Data Field on Email Template

 

Userlevel 1

@cmorse26 THANK YOU! This worked. I cant begin to describe how thankful I am.. Our providor couldnt even work this out.. Thanks again Legend!

Userlevel 5
Badge

Great! Happy to help.

Userlevel 1

@cmorse26 one more thing (if you dont mind) - its working and the emails are firing but the report (shipnment confirmation) is coming up blank. Im choosing the correct report - but when I go to choose the report it is limited and isnt actually showing TemplateID which is Fusion Shipment Confirmation - the below is all I can choose from which is the right report number, but it isnt working for some reason. 
 

Any ideas?

 

 

Userlevel 5
Badge

@Razza83 - I am not sure if you can select a “Template” as they are just saved parameters/filters for running the report.

If it is coming up blank, it is likely not getting the Shipment Number through to the report. There should be an additional “Report Parameters” section where you will assign the shipment number coming from the GI.

 

If this doesn’t resolve the issue, then you may need to save the Fusion Shipment Confirmation report as its own individual report with all the Parameters/Filters pre-set and execute the new report on the email template. 

Userlevel 1

@cmorse26 You are a wizard - thats fixed it.

Thanks so much!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved