IMPORT INVOICES _ERROR CustomerLocationId not found

  • 18 January 2021
  • 4 replies

Userlevel 2

Hello Everyone


I am unanable to import customer invoices , I have the Error “CustomerLocationId” not found. However, all the customers have their adresses   


Best answer by jknauf 18 January 2021, 16:30

View original

4 replies

Userlevel 3

CustomerLocationID doesn’t actually represent an address. Instead that field is a meant to be a unique identifier or Key field for a location entry in the database. This field is typically required for an invoice, as it tells the system which location for a given customer this order is for. If your import scenario does not include this field, I’d expect that’s your issue. I’ve attached a screenshot of the field where this value is actually displayed on the invoice screen in case that helps.

Anyway, best of luck!

Userlevel 2

@jknauf thank you for your answer 


However; for the same customer , I can manually create the invoice (pic below) but I ‘ll have the error message ‘CustomerLocationId” not found when using an import scenario 



Userlevel 3


This could be an issue of ID vs CD then. Usually the value the database stores and uses as the Key (the actual ID) is different than the one that it displays to users (this is usually called the CD behind the scenes). The issue with this is that things like GIs use the Display names as parameters, in which case the CD would also be called the ID which can cause some confusion.

So I think the core issue you’re probably having then is that the import wants the actual ID, but you’re giving it the CD. Either that or Vice-Versa. Hopefully this information can help you troubleshoot, but I’m not an expert in imports so I can’t say definitively how you’d resolve this error. I’d try double checking input parameters are correct (is there one that says CD or perhaps a different locationID field?) or try exporting from a different context if you can to try to get the actual IDs.

Worst comes to worst, if this is your issue I know you could fix it by modifying your input data with an SQL query, or writing custom import logic to convert them on import.

Userlevel 2

I tried with both CD and ID  in my import scenario and I have the same error message :( 

And I don’t have access to the SQL database 

I run out of ideas :’( 


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved