Solved

Business Event and Import Scenario run but no record change

  • 26 February 2024
  • 9 replies
  • 103 views

Userlevel 1

I have a business event that I am trying to make so that it creates an opportunity and a quote for certain business accounts on a regular basis. I have set up the business event to run an import scenario on a schedule and everything seems to work fine, except there is no actual opportunity or quote created.

I set up the import scenario separated from the business event with the exact same settings and source and it runs perfectly. The automation schedule runs correctly and both the schedule and the business event say they run without any errors. 

I have tried setting up a task template (using the business account id as the related entity) as a second subscriber and it creates the task successfully, just without the related entity. This makes me think that there is something wrong with my generic inquiry that is not passing the business account ids properly to my business event. 

Any input would be appreciated!

Thanks,

Drew

icon

Best answer by DrewNisley 26 February 2024, 21:57

View original

9 replies

Badge +11

Without seeing what you have, there’s not a whole lot we’re going to be able to help you with. Can you share screenshots of the Business Event and Import Scenario?

Userlevel 1

 

Badge +11

In your import, it looks like you have OpportunityID mapped to BAccount_acctCD. I’m guessing this is your problem. It should be mapped to the Opportunity ID field of your GI.

Userlevel 1

I have it like that so that it creates new opportunities for each business account. When I run the import scenario by itself without the business account, it works great and creates an opportunity and quote for each business account specified. The generic inquiry is solely to filter the business accounts I want to create an opportunity for. 

Although if there is a better way to do this, I am open to suggestions.

Badge +11

Sorry, my bad. Try this instead: =CStr(0-LineNbr())

Userlevel 1

That formula works and my import scenario still works when I am running it outside of a business event, but it doesn’t work when I use it in a business event.

I checked the business event history and it looks like it is firing the import scenario for all three of the accounts I have marked, but nothing happens and there are no error messages

Badge +11

I’m not sure why this isn’t working, but maybe you can come at this a different way. You don’t need to use a Business Event to run an Import Scenario on a schedule. You can base an Import Scenario on a GI (similarly to a Business Event) and schedule it to run through ‘Process Import Scenarios’. Just make sure when you’re creating the schedule that you add a Condition to filter the Import Scenarios to just the one you want to run or it WILL attempt to run them ALL.

 

Userlevel 1

So, I feel a little stupid here but I figured out the cause of the problem. Our test company that I was using to set these automation schedules has two branches and the account I was signed in as was only able to view one of the branches. I didn’t think about this, but the other branch that I couldn’t see was set up as the default for system actions or something like that. So all the opportunities that I thought were not being created were being created in the other branch which is why I could see the opportunities when I manually ran the import scenario, but not when it was on the schedule. 

I do appreciate the help though Daryl!

Userlevel 7
Badge

Thank you for sharing your solution with the community @DrewNisley!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved