Question

How to have a non-stock item left off shipment and not pull into Invoice?

  • 24 March 2021
  • 8 replies
  • 59 views

Userlevel 1
Badge
  • Jr Varsity II
  • 41 replies

In our test environment, we’ve created a Non-Stock ‘Freight Estimate’ item to add to Sales Orders so we can authorize a credit card payment before the shipment.  The ‘Require Shipment’ box is unchecked and the settings for our Sales Order Preferences, Order Type, Shipping Rule, and Non-Stock Item are identical, but in our Live environment it is left off the Shipment (visually), but is pulled onto the Invoice and shows the Shipment # on the line.  This does NOT happen in testing which is the desired behavior.

 

We have ‘Add zero lines for Items not in Stock’ checked and we give the ‘Freight Estimate’ a quantity of 0.  

 

Does anyone have any info on why a non-stock item that doesn’t ‘Require Shipment’ is being attached on the back end to the shipment..and messing up our invoices?

 

This issues has been driving me and our Partner nuts.  Nobody seems to be able to figure it out, so I’m really hoping someone here can help us out.  I can post a ton of more info if needed.  Thanks a ton for any help!


8 replies

Did you ever get and answer on this?  We have a similar problem.  Thanks.

Userlevel 1
Badge

Similar issue on our end, however it is not non stock item it is pulling the info from the shipment, Shipping Settings, inputs and placing a line item on the invoice that just says the carrier name a price of zero. We too would like that removed.

Userlevel 6
Badge +3

@Noah  Can you please share the configuration of the Order Types and Sales Order Preferences screen? 

Also, please attach the “Freight Estimate” Non-Stock Item screen

Userlevel 1
Badge

No solution yet. @byates we have that carrier line too, but for us it’s far down on the list of issues to resolve.  

 

@Naveen B I’ll get you screenshots of those items tomorrow afternoon.  Have to remove some company sensitive info from them first.  Thanks a lot for taking an interest! It’s really appreciated!

Userlevel 1
Badge

We are using the default SO order type.  We’ve tried mirroring these settings in the test environment and it continue to work there, but not in LIVE.  Thanks again for taking an interest Naveen!  I think my Partner may have opened a case today about this.

Userlevel 6
Badge +3

Hi @Noah  

Thanks a lot for sharing the details.

I have verified this by having this configuration in the brand new instance, but unable to replicate this issue.

This is an issue strange to me. :upside_down:

We may need to think of the customizations side as well. Is there any customization built on the “Create Shipment” action in Sales Order screen?

Have you unpublished all the packages during the off buzz hours and verified in LIVE?

 

Userlevel 1
Badge

Thanks Naveen.  We don’t have any customizations related to shipments or ‘Create Shipment’.  Haven’t tried unpublishing all of our customizations and testing yet.  That’s a good idea.  We have opened a case and my partner and I are determined to figure this out, even if we find a workaround.  Will certainly come back here and post their/our findings.

 

Thank you for taking a look! Just knowing something is a bug or requires a deeper investigation and is not just a setting I don’t understand yet really helps out a lot!

Userlevel 6
Badge +3

Noah,

I just informed you to unpublish the packages in the LIVE, just to eliminate that this issue NOT causing by customizations.

 

Sure, please let us know if you get a response or found anything on this issue. That will helps us a lot.  

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2020  Acumatica, Inc. All rights reserved