How to delete unlicensed tenants

  • 7 February 2023
  • 7 replies

Userlevel 3

I wanted to create a new tenant to use for testing, and when I did, I unknowingly exceeded our license limit of 5 tenants. I was unable to access this tenant, and I thought maybe something went wrong, so I tried creating another. Same problem, I couldn’t access it. So I thought I could create a new tenant and immediately set the status to Test Tenant, but once again I couldn’t access it. So now we have three new tenants that I cannot access. How can I delete them if I cannot access them? 

Thank you for any help. This is driving me crazy. 



Best answer by dhollinden 16 February 2023, 22:30

View original

7 replies

Userlevel 7
Badge +12

Hi @dhollinden 

the tenant is created but user account doesnot exist seems to be an issue for accessing newly created tenants.

As a workaround try to login as “admin” from User screen and try to access the newly created tenant and confirm,

If still not resolved, create a case with Acumatica.



Userlevel 3

Thank you @manikantad18 

I my account has the System Administrator role, and I cannot access the new tenants. I wish there was some sort of super-admin account on an instance that would have access to all tenants. I’m not aware of anything like that. 

I created a case with Acumatica Support shortly after posting here. I’ll update the post here if I find out anything useful. 

Userlevel 7
Badge +16

HI @dhollinden 

Login in from your Main tenant and choose the tenant you want to delete. You should be able to delete it from here. 

If this is a local hosted version of Acumatica, you can delete it right off the server. Go to the Acumatica Configurator and Perform Database Maintenance, Connect to the Server, then when you get to the Tenant Setup, you choose the tenant you want to delete:


Userlevel 3

Thank you @kandybeatty49

We’re using the Cloud hosted version, not local, so I need to delete tenants through the UI. 

I understand what you’re saying, that you can delete a tenant by selecting it on the Tenants screen. My problem is that the problem tenants were not appearing on the Tenants screen. For some reason I did not have access to them, so I couldn’t choose them and delete them. I could see that they exist on the Space Usage page, but if I clicked on them I got a popup saying that I did not have access to them. 

Ultimately I had to request that Acumatica Support delete them. 

Userlevel 3

We had a session with Acumatica support. The problem we were having was that we were logged into our SASS instance via SSO when we were creating new tenants, so we were logged in as Active Directory users instead of with a local account. When you create a new tenant, Acumatica takes the account you’re currently logged into and copies it into the new tenant. If you’re logged into a local account, then you have access to the new tenant and it immediately appears on the Tenants page. If you’re logged into an Active Directory account, that doesn’t happen because a new tenant does not have Active Directory yet. So the new tenant does not appear for you on the Tenants page. It will appear on the Space Usage page, but if you click on it, it will say that you don’t have access to it. 

Userlevel 7

Thank you for sharing the solution with the community @dhollinden !

Userlevel 2

It looks like this issue was present in 2022 R2, but it works in the 2024 R1 Preview version:, so it appears to have been fixed some time in between.


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved