Solved

Authentication In Acumatica

  • 2 May 2023
  • 4 replies
  • 134 views

I am having difficulty sending an authentication token in the headers while trying to populate fields in IN304000. I have obtained the token from the login API. However, when I set the token in the headers of the API to populate the fields in IN304000, I receive a "404 Not Found" error. Conversely, when I use the logout API and attempt to access the IN304000 API, I receive a "401 Unauthorized" error.

icon

Best answer by Vignesh Ponnusamy 11 May 2023, 20:33

View original

4 replies

Badge

Are you facing an issue with your code or in POSTMAN? Some screenshots may help to understand the issue a little better.

Userlevel 7
Badge +4

@osamaaslam49, Also, can you please clarify the Authentication flow you are using? For details on different authorization flow, kindly refer https://help.acumatica.com/Help?ScreenId=ShowWiki&pageid=a8f71c44-9f5c-4af8-9d47-bc815c8a58e7

Thank you, @abhijit  and @Vignesh Ponnusamy , for your helpful comments. I was able to resolve my issues successfully.

Badge

Thank you, @abhijit  and @Vignesh Ponnusamy , for your helpful comments. I was able to resolve my issues successfully.

Could you please share your solution with the community?

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved