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Custom Weeks Can not be Generated For New Year


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Hi All,

 

I was trying to generate Custom Weeks for 2024 Year using the Time and Expenses Preferences Screen.

 

 

But when I save the above records, the below error is occurring.

 

After investigating the issue, I found that there are already few records containing weekIDs of 2024 in the database(EPCustomWeek table) for previous year as below.  

 

I suspect that this should be the reason for above mentioned error message. 

Any idea on this? How can I solve this issue?

 

Thanks

Best answer by Laura02

Hello @charithalakshan49 ,

It looks like this is a known issue in Acumatica. The solution is to contact your VAR and ask them to open a support ticket.

Here is the post that contains details of the known issue:

https://community.acumatica.com/known-issues-232/known-issue-on-the-time-and-expense-preferences-form-if-a-user-had-more-than-100-custom-weeks-for-a-year-when-a-user-attempted-to-generate-custom-weeks-for-a-subsequent-year-the-another-process-has-added-the-epcustomweek-record-error-occured-13610

In case you cannot see the above post (some are available only to VARs):

Issue description

 

On the Time and Expense Preferences (EP101000) form, if a user generated more than 100 weeks for a year by using the custom week functionality, and then tried to generate weeks for a subsequent year, the system displayed the following error message: Error: Another process has added the 'EPCustomWeek' record. Your changes will be lost, as shown in the following screenshot.

 

Root cause

 

This is a known issue for the following builds of Acumatica ERP:

  • All builds of the 2023 R1 Version
  • All builds of the 2022 R2 Version
  • All builds of the 2022 R1 Version
  • All builds of the 2021 R2 Version
  • All builds of the 2021 R1 Version
  • All builds of the 2020 R2 Version

 

Solution

 

We are currently planning to resolve this issue in future Acumatica ERP Versions.

 

Workaround

 

Contact your Acumatica support provider to receive the workaround instructions and any assistance with using them.

 

Laura

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5 replies

Laura02
Captain II
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  • Captain II
  • 3132 replies
  • Answer
  • January 1, 2024

Hello @charithalakshan49 ,

It looks like this is a known issue in Acumatica. The solution is to contact your VAR and ask them to open a support ticket.

Here is the post that contains details of the known issue:

https://community.acumatica.com/known-issues-232/known-issue-on-the-time-and-expense-preferences-form-if-a-user-had-more-than-100-custom-weeks-for-a-year-when-a-user-attempted-to-generate-custom-weeks-for-a-subsequent-year-the-another-process-has-added-the-epcustomweek-record-error-occured-13610

In case you cannot see the above post (some are available only to VARs):

Issue description

 

On the Time and Expense Preferences (EP101000) form, if a user generated more than 100 weeks for a year by using the custom week functionality, and then tried to generate weeks for a subsequent year, the system displayed the following error message: Error: Another process has added the 'EPCustomWeek' record. Your changes will be lost, as shown in the following screenshot.

 

Root cause

 

This is a known issue for the following builds of Acumatica ERP:

  • All builds of the 2023 R1 Version
  • All builds of the 2022 R2 Version
  • All builds of the 2022 R1 Version
  • All builds of the 2021 R2 Version
  • All builds of the 2021 R1 Version
  • All builds of the 2020 R2 Version

 

Solution

 

We are currently planning to resolve this issue in future Acumatica ERP Versions.

 

Workaround

 

Contact your Acumatica support provider to receive the workaround instructions and any assistance with using them.

 

Laura


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Hi @Laura02 . Thanks for the response!.


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@Laura02  Can you suggest any workaround for this known issue?


Laura02
Captain II
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  • Captain II
  • 3132 replies
  • January 2, 2024

Hello,

It seems like the choices are upgrade to 2023 R2 or open a support ticket with Acumatica.

Thank you.

Laura

 


Forum|alt.badge.img+1

@Laura02 Thank you!


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