Solved

Subreport for Kits only sometimes is being passed to Pick List

  • 18 August 2021
  • 3 replies
  • 177 views

Userlevel 3
Badge

Hello Everyone,

 

I am working on a minor edit to my pick list form to print out kit items below items that are kits. I can get the subreport to pass-through just fine when I run the report from SO644000, the pick list screen, by picking the shipment number. When I try to run the Pick List report from the actions dropdown on SO302000, Shipments, and go to Actions → Print Pick list, the subreport does not print on the report.

I wonder if this has anything to do with automation steps. Has anyone had this issue before?

I am having trouble uploading an rpx file here so here are some screenshots:

 

icon

Best answer by podonnell11 20 August 2021, 01:06

View original

3 replies

Userlevel 3
Badge

 

 

Userlevel 3
Badge

Problem solved:

My parameter was [@ShipmentNbr], which was fine for running the Pick List from the Pick List screen. When I changed the pass-through parameter to [SOShipment.ShipmentNbr] I was able to run the Pick List with subreport from the Shipments screen.

Userlevel 7
Badge +4

@podonnell11 Glad you got it sorted out, there are basically these two methods for passing parameters (@parameter, or =[Table.Field]), but sometimes it can make a difference to have the fields specified in the Viewer Fields part of the schema also. Usually you can tell when this is needed because there is an error like ‘does not contain parameter SOShipment.ShipmentNbr0 ← and has this extra digit at the end. Good sleuthing though!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved