Question

Generic Inquiry Parameters Defaulting to NEW Value?

  • 30 January 2021
  • 3 replies
  • 58 views

Userlevel 1

In version 2020r2 v205 (I know… :rolling_eyes: ) I have a couple of GIs that I’ve created that are using the InventoryCD value as my parameter with standard parameters allowing for the display of all items if the parameter is Null.  

When I open the Inquiry, either from the UI or using the View Inquiry action from the Generic Inquiries screen, Acumatica is inserting the <NEW> value, as though it’s expecting me to create a new record.  

 Has anyone seen this before?


3 replies

Userlevel 5
Badge +3

Hi @plmainard This is strange....Not seen this before…

Can you please export XML format of GI and share. We can dig into it and let you know if found anything

Userlevel 1

Hi Naveen,

According to support, it’s because the GI is using InventoryItem.InventoryCD as the parameter filter while having auto-numbering enabled for the Inventory Item segmented key.  Seems a bit strange but I think it’s a bug.  I may need to use a different schema field for the query filter that’s not linked to the Inventory maintenance screen.  Doesn’t make much sense to me, but I will try to find another filter to make this work.  I think there’s one that can be used as a dashboard filter that may work.

 

Thanks for the response though.  

Try setting the Default Value of the paramter to =Null

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2020  Acumatica, Inc. All rights reserved