Solved

"The Save button is disabled." error in an import scenario

  • 19 October 2021
  • 6 replies
  • 1448 views

Hi Everyone,

 

I am trying to create an import scenario to input Amount Paid in the Payments and Applications form (AR302000) and I get “the save button is disabled error”. I followed my mapping manually and yet I am able to save.

This is my scenario:

I unchecked reference Nbr. Commit because otherwise, I would get “Error: 'Reference Nbr.' cannot be found in the system.”

This is my data:

Then I shrunk it down to 1 row because I suspect the error is caused by the payment amount command.

I also tried to swap the Payment Amount command with Action: set Payment Amount to Applied documents and moved it up and down in the mapping order, to no avail.

If anyone knows what I am missing, it would be great.

 

Choenho

icon

Best answer by cduong61 20 October 2021, 02:23

View original

6 replies

Userlevel 7
Badge +17

Hi @cduong61  I just worked on this import scenario and I can able add the record in Documents to Apply tab with Amount Paid amount successfully.

Please find the import scenario here. (21 R1 version)

 

 

Thank you for your response Naveen.

I managed to make it work by including a payment summary/reference number as you did in your example. It is strange because in my instance that field is not required as it is an automated number. It seems that it works no matter what number I use in my excel sheet, the system will give the correct sequential number after my import.

However, how is it possible that you to made it work without a command for Payment Amount (Top right for $500)?

Userlevel 7
Badge +17

Hi @cduong61 

I have created a Sales Order and made a payment with $500. Once we open the payment, “Payment Amount” will be populated automatically.

In my import scenario, I have applied Sales Order Invoice to this payment, then Payment and Invoice both documents changed to Closed status as expected. 

Understood,

In my case, it will be to apply partial payments to multiple invoice at the same time.

Thanks for your help.

 

Userlevel 3
Badge +1

I’m Getting this Save button is disabled, ive been using this import since we implemented Acumatica once a week since November.  This is the first time I ran into this error.  There are multiple lines that have been processed but still have the save button is disabled.  The error message in red says there is 5 error lines, but I filter not processed 

(Sales Load import)

Upon further investigation, the 3 lines that didn't load, were duplicate invoices.  

Still not sure why the save button error shows up.

 

 

Badge +18

Hello @jyounes ,

Is it possible Acumatica said “the save button is disabled” because the import was trying to update a sales order that can’t be edited?

If a Sales order is completed status, we can’t manually save any changes to the completed sales order. When importing to a completed sales order, an import scenario may give a message “the save button is disabled” because it can’t save to a completed sales order.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved