Importing Journal Transactions: The Post Period is being overwritten by the transaction date's default post period

  • 16 November 2020
  • 9 replies
  • 141 views

When I import journal transactions, I have multiple line details grouping to be one GL batch by JE number and post period. Each GL Batch has the same Post Period, but some lines within a batch have a different transaction date in the source file (I’m brining in historical SL GL batches and its common for SL Batches to span multiple dates in one batch). In Acumatica, if I bring in the post period and transaction date at the batch level, Acumatica will just default the post period that the last transaction date is in. The only way my GL batches get the proper Post Period is if all the line details share the same date, or if their dates share the same default post period as the post period I want to load. Let me know if this isn’t making any sense, but I have ran into this issue with multiple implementations and I have been trying to find a solution.

Thank you!

-Landry


9 replies

Userlevel 6
Badge +6

@ndahayol79 I assume that you are using an Import Scenario to process your import file? The default scenario that ships with Acumatica doesn’t allow you to specify the post period, so I assume that you have your own import scenario or that you modified the one that ships with Acumatica.

In any case, I think that simply setting the post period *after* you set the date in the import scenario mapping will do the trick:

 

 

I created my own that works when I inactivate the Transaction Date line. It doesn’t work when I add the post period after the transaction date.

Userlevel 6
Badge +6

Can you check if you format the post period like it is on screen? There’s a “-” between the month and year.

I have tried that. I have also tried to hard code a period directly into the import scenario and I still ran into the same issue. 

Userlevel 6
Badge +6

@ndahayol79 if you only set the financial period and skip the date, does it actually set it? Your import scenario looks 100% right otherwise, it would just go through all the steps in the mapping in the same order a regular user would do it from the web UI -- the default post period should be overridden by what you set there in your scenario.

When I only set the financial period and skip the date, the import does set the post period correctly. Part of me thinks it has to do with the grouping of the lines potentially? Maybe I have to make my own primary key for the post period? I am trying to think of a way to solve this.

Userlevel 4
Badge +4

Hi @ndahayol79 

I have tried importing GL transaction with different post period with reference to transaction date, using our sample scenario you can find Demo tenant. It worked fine. I am attaching the XML for your reference. 

Imported transaction 

Hope this helps,

Regards,

Right, like I said earlier, if the transaction date is the same, i.e. your example, the post period will be entered properly.

BUT 

In your example if the top line’s date was different, i.e. 01/02/2013, then the post period would have defaulted to 01-2013.

Does this make sense?

@ndahayol79 did you manage to resolve this issue. I’m experiencing the same thing and have tried just about everything to no avail.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2020  Acumatica, Inc. All rights reserved