Solved

How to switch tenant?

  • 26 November 2021
  • 7 replies
  • 145 views

Userlevel 1
Badge

I am unable to select the tenant with Edge and Firefox.

At the login screen there is a tenant preselected that cannot be edited but deleted. If I enter my credentials without a tenant in Chrome, a second dialog appears to select the tenant.

But with Firefox or Edge this second dialog is skipped. How can I change the mentant then?

 

My instance is vesion 2021 R1 Build 8.013.0000.40 [21.113.0011]

icon

Best answer by mhaps 29 November 2021, 07:47

View original

7 replies

Userlevel 7
Badge +12

Hi @mhaps  This is strange!

I have worked on multiple 21 R1 builds but did  not see this issue at all.

Have you tried in Chrome Incongnito window and verified?

Userlevel 1
Badge

Right, with an Incognito window Chrome does also not show the tenant select screen.

So, what’s the way to choose the tenant?

Userlevel 7
Badge +12

@mhaps  After login to any of the tenant, are you able to see the tenants from there you can go to the different tenants.

 

 

Userlevel 7
Badge +8

Hi @mhaps 

Looks like following option was enabled while setting up the instance:

  • Secure Company on Login Form: This check box defines whether all tenants of the instance are displayed on the welcome page. When the check box is selected, the box where the tenant can be selected from the instance login page will not be displayed until a user enters login and password. After the user is authorized, the system displays a list of companies where the user has the user account that was entered.

https://help-2021r2.acumatica.com/(W(2))/Help?ScreenId=ShowWiki&pageid=649153e7-ec83-4173-a866-01f8c526b84a

  • try clear browser cache on all browsers 
  • based on user name and password, the tenants should list

Let us know the result. 
Regards,

Userlevel 6
Badge +6

Hi @mhaps Attaching the screenshot showing the option referred by @vkumar .

 

 

Userlevel 7
Badge +12

@mhaps  I just created a new instance with Secure Tenant on Login Form with multiple tenants, once we enter the credentials, as next step it is asking us to choose the tenant to login to the instance.

In your case it might be an issue with the browser caches, I have verified in Chrome, FireFox and Microsoft Edge, in all three browsers I can able to select the tenant and login to the instance, and also I can able to switch between the tenants as well.

 

As first step, it is asking us to enter the credentials without tenant selection

 

After login to the instance, I can able to switch between the tenants

 

 

Userlevel 1
Badge

Finally I figured it out. There are two users with the same name, assigned to different lists of tenants. The browsers have stored different passwords, so I was not aware that l logged in with different users.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved