Device hub setup

I am trying to setup Device hub on our server, but am getting a permissions error with the

connection to ERP...

[Error] There was an error opening the connection: StatusCode: 403, ReasonPhrase: 'Forbidden', Version: 1.1, Content: System.Net.Http.StreamContent, Headers:

So this results in Acumatica (MYOB Advanced in Australia) not seeing the printers that are setup in DeviceHub, but if I add the printers manually in the ERP then the DeviceHub recognizes them as setup… but still nothing is found in Acumatica.



Best answer by Brian Stevens 27 July 2021, 14:28

View original

13 replies

Userlevel 6
Badge +4

What do you mean by “setup Device hub on our server”?  Configuring Device Hub can be a little tricky, but it works for me.  Here are a few steps, and the first one will explain why I am confused when you say “on our server”.

  1. Setup an account that will be used to login to Acumatica with Device Hub, ensuring proper access for Device Hub to login and function.
  2. Identify a PC at the remote destination that can login to Acumatica via the website.
  3. Setup the printer on the remote PC and ensure it can print locally.
  4. Enable Device Hub in Enable/Disable Options on the server.
  5. Install Device Hub on the remote (client) PC, using the same Acumatica version as the server.
  6. Configure the connection settings for Device Hub on the remote PC.
    1. Give the local Device Hub instance a name (Device Hub ID) on the General Tab.
    2. Enable scale and/or scanner support if desired.
  7. Under the Connection tab, enter:
    1. URL: The same URL you use to connect to the Acumatica instance
    2. Login: The user id that was setup for Device Hub access.  (You should have been able to login with this account in step 1.)
    3. Password: The password for the account.
    4. Tenant: The company name shown on the Tenant screen in Acumatica.  I believe this is the Login field on the tenant screen, but it may be the Tenant name.  (They are the same in my instance.)
  8. On the Printers tab, setup the printer:
    1. Click the Add button.
    2. Enter a name for this printer.
    3. Select the printer.  (This will be the Windows printer that is setup on the PC.)
    4. If this is for a label printer accepting raw label printer language (i.e. EPL or ZPL) then check the Raw Mode checkbox.
    5. All other settings should be fine as default values.
  9. Press the OK button

At this point, the Log screen should show that the printer has been initialized and that it is “Starting monitoring tasks”.  If it contains an error at this point, please post a screenshot of the error.

If everything appears ok in Device Hub, go back into Acumatica and navigate to the Printers screen (SM206510) under the System Management workspace.  If the Device Hub on the remote machine is configured properly and able to communicate with Acumatica, then clicking the Update Printers button should poll the Device Hub at the remote location and provide a list of Device Hub ID’s and their respective printers.  I believe you can set these up manually, but the Active checkbox is only checked if Acumatica can communicate to Device Hub on the remote PC and see the printers.

Common issues (for me):

  1. Typo in the URL, Login ID, or Password (make sure you are using https:// in the URL and that you have a cert installed on the Acumatica instance.)
  2. Wrong Tenant specified
  3. PC doesn’t actually have connectivity to Acumatica (network issues)
  4. Version of Device Hub does not match version of Acumatica - This is a big one.  When I upgrade Acumatica, I have to upgrade my Device Hub(s) to match.  Not sure if this is supposed to be an issue on minor version updates, but it is for me every time.

I may have forgotten something.  I looked at my working Device Hub configuration and Printers screen in Acumatica, but it’s possible I still left out a step.  Please post error messages if you follow these steps and continue to have issues.

Userlevel 6
Badge +4

Edit isn’t working…  Opening paragraph, I refer to “first step”, but then I wrote more detail.  Steps 2, 3, and 5 combine to explain setting up Device Hub on a remote PC.  That’s why “on our server” confuses me.

Thank you for your reply.

So we are in the process of upgrading from our current ERP which is on site, and runs on  a server with several network printers configured, I have installed Device hub on one of these servers.


So this is where I think my problem is..

  1. Setup an account that will be used to login to Acumatica with Device Hub, ensuring proper access for Device Hub to login and function.

What license do I need for the user? Full API or a limited API (supplied for free by MYOB).

I have tried both, and have the same error


Here is the screenshot with the printers not added in ERP,

And now with the printers added manually in ERP (and correct, they are not active..) (disregard the office printer)


Userlevel 6
Badge +4

I do all my development from the free 2 user install.  I’m not sure if Device Hub is running entirely on port 443 (SSL) but I think so.  I followed the steps I shared above, and my own environment works like a charm.

Per the Acumatica Help (click me) you need the user on device hub running with admin privileges.  Are you using a user with that access?  I haven’t seen that error before, so I am not sure if this is a communication issue or a user access issue.  Forbidden from a web server typically means invalid credentials, but again, I may be going in the wrong direction.

If you can login with the user login and password you entered in the config and have the Tenant right (exactly matching what is in the tenant screen of Acumatica), this is beyond anything I know.

Also, I have multiple tenants, but the help says to leave the tenant box empty if you only have 1 tenant at that URL.

I do have my user setup with the admin Role.

What license have you applied to the user?


It seems to me that the Device hub can login and see Acumatica printer setup, so that is good…

But the problem is that Acumatica cannot see the device hub, can it be a network issue, maybe

with our router / firewall?

Userlevel 6
Badge +4

I don’t remember any firewall issues on our end, but  it is possible. Someone else handled the production instance.  Your network team should be able to monitor for blocked traffic to see if another port needs to be opened.  I do all my work without a license applied at all as I am a developer.  I just enable the device hub in enable/disable features.  I work in a relatively closed environment, and it just works.


you may be into something with blocked ports, although I was under the impression it all works under port 443 with SSL or port 80 without SSL.  If your network team can’t find any blocked traffic, I am out of ideas.

Userlevel 6
Badge +4

When I got to the office, I tried a few scenarios.  I get completely different errors if I try to login with a locked or disabled account or with any other bad login information, but I was able to reproduce your error!

On the tenant screen in Acumatica, you need to locate the tenant you want to login on.  The help says to leave the tenant blank in Device Hub if you have only 1 tenant.  I have 2 in my instance.  On the tenant screen, you need to get the Login Name and Tenant Name.  Mine match, so I’m not sure exactly which one Device Hub wants.  The help says Tenant Name, but it seems like the web services class wanted Login Name.  Try one and if it doesn’t work, try the other.



Here is where I left mine blank (having 2 tenants in my instance) and got your error message.  Filling in “Company” in my case as the Tenant fixes the issue for me.



Awesome work!! Thank you for your efforts, I really appreciate it.

This does give me somewhere to look, but unfortunately the tenants are still managed by

our system implementers -we are not live yet.

Our Tenant name and login are identical in each individual tenant (we have 3 tenants), but do contain spaces & other punctuation.. maybe this is causing the error.


Hi Folks,

I am experiencing the same issue with Devicehub trying to connect to our Acumatica tenant. Were you able to get to the bottom of the issue? I am in Australia where Acumatica is sold under the name MYOB Advanced as a SASS product.

All login details are set, including Tenant.

Is the 403 error referenced relating to a HTTP error? Could the issue be on the cloud server blocking the traffic to that port?


I appreciate any guidance on this issue.




Userlevel 7
Badge +10

I was able to get the error to go away by removing the Tenant reference since only one tenant.

Userlevel 1



@davordob and @mcl0001 - did you ever get the DeviceHub working? We are having the same issues, also a MYOB Advanced site.


Thanks heaps




@BeverleyM  Unfortunately not, and have given up on it.

I suspected that maybe it was my login name (being an email address), and that we have

multiple tenants, but am not sure..


When I installed Acumatica as a test system and ran the Device Hub it worked flawlessly using

the default admin login, but cannot get the same result in  MYOB Advanced.


Userlevel 1

Hi @davordob 


Thanks for the response, we figured it out after I posted the reply earlier and have successfully got it working at the client site. 

It does seem that the user you use for the DeviceHub needs to be a licensed user as well, can’t just have the API License assigned, needs another license as well. To test this we used the External Accountant license and that’s how we got it to work.


Hopefully that works for you as well.





About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved