Solved

Add Date of Service Column on Invoices

  • 13 September 2021
  • 8 replies
  • 72 views

I’m looking to add a "Date of Service" column to the Services > Invoice > Details grid.

I'm trying to add a column on the Details tab of the Invoices screen to show the Appointment Date for charges listed on the Details tab. It pulls this information just fine on one of my reports (relationships shown on the bottom row, Left join FSARTran to FSAppointment, in the attached image), but when I duplicate this join (the FSAppointments table to FSARTran) in the Generic Inquiry for the Invoices page, the fields are all there, and it saves with no errors, but it begins generating errors for our users. Anyone know how to add a column for Appointment Date to the Details tab of the Invoices screen?

I found the info (see image) for tying the Invoice to the Appointment Dates in the report file SO643000.RPX. All the fields seemed to be there and the tables appeared to add and relate without error. However, once I clicked Save, the system began generating errors when attempting to populate the Invoices page. It returns The multi-part identifier "FSARTran.AppointmentRefNbr" could not be bound.’

Anybody have any ideas? Thanks in advance.

 

icon

Best answer by Naveen B 15 September 2021, 19:56

View original

8 replies

Userlevel 1
Badge

2 things I would say here.  One we need to know how the line above is setup to relate ARTran to FSARTran and two you need to list the Service order type to the connection between the Tran and the appointment.

 

The other option would be to link by AppointmentID which is in the ARTran and FSAppointment table.

Userlevel 6
Badge +9

Hi @davidpoole21   Are you verifying this report in newer version like (2021 R1) ?

If yes, the above fields modified in newer versions. Please join the tables using below conditions. 

Hope this helps!

 

 

Thanks to Greg Lang and Naveen B for the responses.

Greg is right; I should have included more info.  I didn’t see an AppointmentID in the ARTran table, so I couldn’t link them that way.

Yes, Naveen, we’re using 2021 R1, so maybe that explains part of it, but when I tried your suggested join conditions, I got:

 

Here is my setup:

 

 

Any further help is greatly appreciated.

Userlevel 6
Badge +9

Hi @davidpoole21  FSARTran should join with ARTran instead of ARTran joining with FSARTran and check once.

 

 

Now I get:

 

I’m sorry to be so dense, but I don’t understand what you mean by “check once.” My config now is:

 

 

Userlevel 6
Badge +9

Hi @davidpoole21 

In the above screenshot, “Table Relations” grid, you are joining the ARTran with FSARTran, which is causing the issue.

Can you please change like below and verify.

Join FSTran with ARTran

 

 

Sorry, I got an error and the system switched them back without my noticing.

 

That looks like it might be working now. THANKS SO MUCH!

Userlevel 6
Badge +9

@davidpoole21 Great :) Thanks for the update.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2020  Acumatica, Inc. All rights reserved