Cannot open this record for editing. The form PR20300 does not contain it.

  • 17 December 2021
  • 10 replies

Userlevel 3

Acumatica 2021R2 - the Admin user can open the Employee Payroll Settings form w/o and issue.  We’ve added two users with the Administrator role and both are experiencing the error:

Cannot open this record for editing.  The form PR20300 does not contain it.

What can cause this error?  I’ve tried adding all the PR Roles to my own User ID but still experience the same issue.

Hoping the community can point me in the right direction.

Thank you,

MIke Lupro


Best answer by vkumar 18 December 2021, 02:42

View original

10 replies

Userlevel 7
Badge +9

Hi @mlupro87 I created a “test” account and was able to replicate the issue. Are you getting the same when trying to click on an Employee ID? Please confirm.


Userlevel 3

Yes, it happens when I click on an employee ID.

Userlevel 3

I filed a case with Acumatica #219889 so we may get an answer in a couple of days.

Userlevel 7
Badge +11

Hi @mlupro87 

Error is coming up due to Company/Branch access role not assigned to the user. 

I could replicate the issue on my demo instance. Assigning Company/Branch access role resolves the issue.

  • Check the Company/ Branch profile and identify the ‘Access role’
  • Assign those roles to the user 


Hope this helps,


Userlevel 3

Assigned myself and my associate to the Branch Access role and issue is resolved.  THANK YOU.

Mike Lupro


Userlevel 7
Badge +11

@mlupro87 you are most welcome!



Userlevel 1

I am seeing this issue as well - but in the bank reconciliation screen.  The error is thrown when trying to open a closed rec.  I confirmed the users have access to all the roles for company access and the error still occurred. I then turned off the “restrict visibility by branch” feature and now we can open those closed recs. It is inconsistent behavior however as a number of their other bank accounts have this feature turned ON and we have no problem getting into closed recs.  Any ideas?

Userlevel 7
Badge +11

Hi @lbrewster57 

That has got to do with the branch you logon to.

  • If you logon to a branch that is not linked to the Cash account,
  • and Cash account has ‘restrict visibility by branch’ enabled,

it wont allow you open the Bank reconciliation statement for above Cash account. Here are couple of screenshots to explain this : 

In this case, ‘restrict visibility by branch’ is enabled on Cash account 10700 and its linked to Product wholesale branch.

I logged on to another branch and tried to open the reconciliation statement.

Hope this clarifies,



Userlevel 1

Hello!  Thank you for the reply.  I did figure this out shortly after I wrote that post - but it is certainly helpful to have the screenshots you added for the community to see at large.


@vkumar I have the same issue but from the sales order screen SO301000.

We have 3 different order types.
2 of them give this error message but one of them does not.






About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved