Solved

MySQL Column Width Bug

  • 10 November 2021
  • 2 replies
  • 80 views

Userlevel 4
Badge

We're having the issue described below with Acumatica and cannot find a solution. We have an open ticket and Acumatica support has been sporadically working on it for several weeks now but no answer. They can't reproduce it and so have done a screen share to look at it on my machine, but to no avail. Posting here in hopes that someone can help

We've tried a fresh install on other computers and get the same error.

Environment:
Acumatica 2021 R2
MySQL 8.0.26 Community on Windows Server 2019 Standard

When adjusting the column width of a GI, the following error message is thrown:

I have tried various combinations of charsets on the database to no avail. I have also tried different column types with the same result

Here is the database character setup:

 

The database:

 

The table:

 

This Stackoverflow article may shed some light:
https://stackoverflow.com/questions/37062643/incorrect-string-value-mysql-issue-when-inserting-utf8-text-into-a-latin1-col

icon

Best answer by Freeman Helmuth 11 November 2021, 20:37

View original

2 replies

Userlevel 4
Badge

For some reason my images of the collations are not posting

I’ve tried setting up the database/table/column collations as UTF8, utf8mb4, latin1 and several others with 0% success.

 

Per another members research,  this may be an issue with the way columns are named in MySQL. Acumatica is using a MySQL reserved name:

 

Userlevel 4
Badge

Update: Don't try MySQL 8.0+ Stick with 5.7. It works great.


We've downgraded and the issue went away

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved