Solved

Business Event not triggering

  • 23 February 2024
  • 4 replies
  • 81 views

Userlevel 2
Badge

Hi,

A business event was set up based on the generic inquiry to be triggered each time a prepayment request has been approved by the Procurement manager. it was working fine until recently when it stopped, I checked the business event history, none was processed and no failed ones. Has anyone else run into a similar issue?

 

icon

Best answer by lorach 26 February 2024, 07:48

View original

4 replies

Userlevel 2
Badge

Me too,

Business Event & Automation Schedule on Release Expense Claim are not triggering (2021 R2) 

 

Look forward for the solution here. 

Thanks in advance.

Userlevel 7
Badge +12

Check on your GI that for every table on the GI the key fields of that table are on the Result Grid that is generally what i find is the cause of it not triggering

Userlevel 2
Badge

Hi @dcomerford 

Thank you, I checked the key fields everything was fine, though I eventually got what was causing the issue, it was because of workgroup since it was included as one of the trigger conditions. and apparently the person who was initially in the workgroup had been removed from it, but he was still approving in a different workgroup hence the BE not triggering.

Userlevel 7
Badge

Thank you for sharing your solution with the community @lorach!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved