Solved

Error: another process has added the Batch record

  • 14 February 2022
  • 5 replies
  • 396 views

Hi I have this issue in invoices when I tried release from hold and change the records, and I don’t know how to resolve this.

The version of acumatica is  20.216.0024 R2

please help me.

Thnk u.

icon

Best answer by Laura02 15 February 2022, 17:36

View original

5 replies

Userlevel 7
Badge +17

Hi @emmanuelmeza62  Have you tried the below options?

  • Do you have any customizations on this screen?
  • If yes, have you unpublished your customization and verified it? and everything is good. So that we can confirm that this issue causing by your customization.
  • If this is occurring from your customization, can you please share your code here.
Userlevel 7
Badge +11

Hi @emmanuelmeza62 

The trace log has reference of custom object (highlighted on following screenshot PX.Objects.SO.Cst_SOInvoiceEntry). As mentioned on previous post. check the result with customization unpublished. 

Regards,

Hi, when I unpublish all projects, the error still there.

 

Userlevel 7
Badge +17

@emmanuelmeza62 When there is no packages published and still, seeing this issue 😲.

Please raise a support ticket with Acumatica to identify the root cause of this issue.

 

Badge +18

Maybe, look also at the Batch numbering in Numbering Sequences screen and make sure it looks ok, has correct last batch number used, has correct numbering for each branch, is not set on manual numbering, etc.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved