We are upgrading from Acumatica 2021 R1 to 2022 R2; in SandBox the Invoice form is duplicating every line on invoices that use UPS as the shipper but not all. Form worked 100% in previous version..

  • 15 February 2023
  • 15 replies



The company I work for DES is upgrading their Acumatica from 2021 R1 to 2022 R2.  We currently have a Sandbox setup for testing purposes and we are having a strange issue with the Invoice form. 

We had NO issues WHATSOEVER on 2021 R1.  Now all of a sudden on 2022 R2 the Invoice is duplicating every line item on certain invoices that are using UPS as the shipper (best I can tell so far).  I went over the ENTIRE FORM, every join, every filter and I am 100% sure not one single thing changed in this form.  It just SOMEHOW picked up an issue with 2022 R2 and I have no idea as to WHY?


I looked through almost 300 invoices trying to find a pattern to when this is occurring and out of all of the invoices I found a total of 5 that seem to be effected by the strange behavior.  This is only occurring in NEWLY CREATED Invoices as well (meaning created on the Sandbox).  Any historical invoice looks and prints properly.   


Here is a picture of the issue at hand, if you look at the line items they are all duplicated.  Yet the total price is correct so the math is working but something is causing those lines to duplicate even though nothing has been changed on the form at all.


Invoice is duplicating line items.


What should be showing up in the tracking numbers box is an actual tracking number.   A few of the newly created invoices in 2022 R2 with UPS DO work and have actual tracking numbers.  In EVERY SINGLE CASE where the line items are duplicated it has that Sample-Label text in the tracking number section.   This may or may not be relevant but that is the only correlation I have found so far other than the invoices that are having the issue are being created in the new version of Acumatica 2022 R2.


When I go to trace I am not seeing anything wrong, no exceptions.   If this was a normal app I was troubleshooting I would watch the console to see what is generating the lines but I can’t do that with Acumatica (that I know of at least).  We also don’t host it, it is hosted BY Acumatica.  So I don’t even know where to being to figure out WHY this is happening?  I couldn’t seem to find any good information as far as ALL of the technical differences between 2021 R1 and 2022 R2 as I thought maybe if I look at that I would spot something but I couldn’t find anything other than VERY general information.   If I turn off the custom forms of course the line items are working but that is a VERY BASIC form so that doesn’t really mean much to me.  

Here is a picture of a WORKING Invoice that also has the tracking.

An Invoice that is working and shows the tracking number properly.


Now I just noticed one other potential clue (maybe).  The one that is working is CLOSED, all of the others are open or have a balance due or something but they are NOT closed.  Not sure why or IF this matters but it was another difference I noticed.


I will also attach the form itself.

If anyone wants to see anything else or needs any other information please let me know and will HAPPILY post it.  I have no idea how to figure it out beyond where I have gotten this. 


Thank you in advance, 






Best answer by darylbowman 17 February 2023, 21:29

View original

15 replies

Userlevel 3
Badge +1

Could you attach the RPX report file as well? The RPS file in your zip attachment requires login credentials.

Badge +11

There were some data tables that changed in 22R2. I’m guessing your invoice has some conditionally hidden rows using a field or table that no longer exists, which instead of conditionally hiding, shows no matter what, leaving you with duplicate items.

UPDATE:  The one invoice I thought worked above 017714 was actually done RIGHT BEFORE they setup the sandbox so it was not made in the new version like the 5 problemed invoices were.  

I will remove that picture.


Sorry about the .rps vs the .rpx I always get them mixed up; should have looked at the file size.

I am attaching the .rpx file right now.  

Is there a list someplace of the data tables that changed?  I tried to find release notes for 22R2 but the information I could find was extremely general, nothing specific. 

For reasons unknown I can’t seem to EDIT my original post to remove the original attachment OR to remove the picture.  Don’t understand why I wouldn’t have the ability to modify my OWN post?!?


Thank you for the replies so far I greatly appreciate it!


Here is the .rpx file. 

Sorry again this site is not allowing me to remove my original attachment or edit my OWN post.


Badge +11

I believe you can only edit your own posts for 15 minutes (or something like that) after posting.

Userlevel 2

Do you have carrier accounts setup on the customer? and if so do you have more than one carrier account on the customer?


Userlevel 7

Hi @scottm99 - @darylbowman is correct that there is a time limit on editing one’s post (60min). After that you need to clarify in comments as you have.

Sorry for the delay, nobody in the 5 cases where this duplication issue is occurring has any of their own carrier accounts.


UPDATE:  We re-created one of the same customers with the same items and did everything the same way except we used Will Call instead of UPS and it still duplicated so apparently the UPS Part even though it was on the 5 effected invoices doesn’t seem to be relevant.  It was just the only pattern I could identify.  So now I am at a loss, no errors, nothing in trace, no idea why these lines are duplicating yet it isn’t being counted when the invoice is totaled up.   

I would expect to see SOME kind of an error if a table was changed or missing wouldn’t you?  Like Table X doesn’t exist in the Database, SOMETHING.  But to get no errors and just have lines just decide seemingly on their own to duplicate I just don’t understand and why only 5 invoices?


Badge +11

Try this

First THANK YOU @darylbowman for the reply, I greatly appreciate it.


Second I am not sure I know how to use an outside .rpx file?  I double click on the file and it opens the report editor, and it doesn’t have the coloring and it is acting like it isn’t connected to anything.  If I hit preview it gives an error.  I went into built schema and added our server and my login info and hit apply and it still didn’t change the look of the form and it still wouldn’t preview.  I did try to save it to the server anyway but it just errors out.  How do I get that form into our Sandbox?   I feel like I a missing a step someplace



It should look like this:


Thank you very much!


Badge +11

Load the file in the Report Designer, then use the Save to server action at which point you’ll need to connect to your Acumatica instance. Make sure to save as a new version so you can revert if necessary.


It looks different because the report using a template which isn’t being loaded because the Report Designer isn’t connected to your Acumatica instance yet. After the report is saved into your instance, you can use the Open from server action to reload the same report, at which point it will look correct.

Thank You very much @darylbowman for the form and the reply!


I closed everything down and started over and this time it seems to have worked when I went to preview it asked me for my credentials and it displayed properly.  I uploaded it and Save it as a new version (of COURSE :)  ) but unfortunately it is STILL duplicating the line items.

I still greatly appreciate the help!



Badge +11

As far as I can tell, you have several custom tables joined into the report. I would removing the last four relationships and see if you can get the lines to show up right. You’ll probably have to strip down the report in order to get it to function after removing the tables. If you can figure out if this solves the issue, you can reason out where the issue lies, and then possibly why it’s happening or what is different about those Invoices.

It very much seems like there is nothing actually wrong with the report, and more like there is something different about those Invoices, which could be a backend data problem. It seems like one of the joins is causing extra rows to be returned, but I can’t figure out which one. 

Userlevel 3
Badge +1

I agree with @darylbowman on removing DAC’s from the report. The custom tables seem like the most likely culprit of this issue, but it makes it impossible to try to test or recreate without having your schema.By removing the joins, you should be able to tell where the duplication is.

Another area to look would be the subreport used for tracking numbers. You mentioned all duplicate records seemed to have the  same  “Sample Label...” in that subreport, so I would make sure there’s no extra data in the tables that subreport is querying.


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved