Units not totaling in ARM report

  • 4 March 2024
  • 7 replies

Userlevel 4
Badge +1

I created an ARM income statement with a unit set. My understanding is that SUMMARY (see below) should sum up the nodes underneath it. When I run the report, there is data in each of the nodes. But when I click SUMMARY it’s empty. 

I did it this way for another income statement (different site) and it works. Haven’t been able to find any difference in settings, or anything that would cause this. Anyone have an idea?

Below is a screenshot of the unit set:




Best answer by jhouser 8 March 2024, 21:21

View original

7 replies

Badge +18


I recently had the same problem.  I’ve never before needed to use Calculations in a Unit Set, to get them to roll up properly. Acumatica Support had me add a Calculation to the rollo-up node, and it worked.

Go to the Root so you can see the Summary node … shown above in your screen shot.  Add a calculation in the VALUE column beside “Summary of All Units”:

=@Unit1+@Unit2+@Unit3+@Unit4  etc. (Use your actual Unit Codes that are hidden above.)

This solution worked for me; I hope it works for your roll-up too.  I’m not sure if this is an intentional change in the software. I happened to be working with 2023 R1 at the time.



Userlevel 4
Badge +1

@Laura02 Thanks! For some reason it says the first unit in my expression is invalid. I tried removing and starting expression with different units, and it also says they are invalid. 



Userlevel 2

I would do the following to see where the issue may lay:

1. Check Unit Name: Verify that the unit name '@01DEFAULT' is correctly spelled and matches the actual name of the unit in your unit set. Ensure there are no typos or extra characters in the unit name.

2. Use Correct Syntax: Make sure that the unit name '@01DEFAULT' is preceded by the '@' symbol in your calculation expression. The correct syntax should be like this: =@Unit1 + @Unit2 + @01DEFAULT.

3. Unit Configuration: Ensure that the unit '@01DEFAULT' is properly configured in your unit set. Check the settings and properties of the unit to make sure it is set up correctly for use in calculations.

4. Data Availability: Verify that there is data available for the unit '@01DEFAULT' in your ARM income statement. If there is no data or if there are filtering conditions that exclude data for this unit, it may result in the error message.

5. Special Characters: Check for any special characters or spaces in the unit name '@01DEFAULT' that could be causing the error. Remove any unnecessary characters or spaces from the unit name.

Badge +18


If you’re certain the spelling and syntax is correct, you may need to open a support ticket.

If the first branch or company has no activity in the month being printed, try posting $1 debit and credit to the same account (any account) to create activity in the period/year you are printing… just to rule it out as the cause of your problem.

Another good troubleshooting step is to see whether the roll-up works with just two companies that you know have activity, then add the rest in one-by-one.  I wonder whether there could be a limitation in length of the calculation formula? If so, exceeding the maximum length of the calculation formula would be ruled out during this test.

Let us know what you find.  Thanks!


Userlevel 4
Badge +1

Thanks @Laura02, I did decide to open a ticket. There’s definitely data in the unit. I’ll share once I have resolution. 

Userlevel 4
Badge +1

@Laura02 and @quinnobryan, thanks both. Looks like the issue was mistyping one of the unit codes. For some reason the error message mentioned the first one, even though it wasn’t the mistyped one. 

This solution worked, but it removed the drill down functionality from the rollup, because it’s a calculated value rather than a data source. Didn’t like that, then remembered that my sales demo has a rollup P&L. In that one, each unit is a branch, and in the rollup they specified a beginning and ending branch.

Since my units are subaccount instead of branches, I tried specifying a beginning and ending subaccount for this one (see screenshot below). It worked, with the drilldown capability intact. 

Wasn’t necessary in prior versions. Not sure why this was changed. 



Userlevel 7

Thank you for sharing your solution with the community @jhouser!


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved