OData Credentials Don't Work

  • 4 January 2024
  • 4 replies

Userlevel 3


I am trying to access OData to eventually pipe data to Excel but I cannot get my credentials to work.  I am using the URL http://<application site domain>/odata/

We only have one company so there is nothing to add after ‘odata/’, although I’ve tried that as well.

I am then prompted for credentials and I enter my Acumatica username and password, and the credentials are invalid.  I have checked the box for OData4 User for my username.

What am I missing here?



Best answer by gbrazelton14 4 January 2024, 22:49

View original

4 replies

Userlevel 7
Badge +16

HI @josborn 

Did you happen to see the help?

Also, have you tried to give user for OData?

This may help also:

Userlevel 4
Badge +1

Hi @josborn ,

A couple of notes on OData after wrestling with it for a few years:

  • A dedicated login for OData feeds seems to be the way to go.  Then you can better tweak access rights and set the password to not expire.  After upgrading to 23R2, there were a lot of forced access rights changes, and I had to add all the “Viewer” roles to our OData login.
  • A lot of my Excel tools use multiple OData feeds.  If you Refresh All with the wrong credentials (like password), Acumatica will register that as multiple failed logins and could temporarily lock the account.  You can unlock the account in the Users screen, then try again.
  • If the wrong OData credentials are entered (at least in Excel), it will save them.  You need to clear them out and start fresh.  Go to the Data tab > Get Data > Data Source Settings.  Select the URL that got saved for your feed, and click Clear Permissions.  This will then get you to enter your credentials again.
  • I would still use the company name after the /ODATA/ , but we do have multiple entities so I can’t confirm if you need to do that.

Hopefully some of that is helpful, good luck!


Userlevel 3

Hi @Kandy Beatty,

Thank you for your reply.  From what I understand the login username is userid@tenant.  Our Tenant has spaces in the name which I think may be preventing it from working.  Do I need to remove the spaces from the tenant name?



Userlevel 4

@josborn - Since you only have one tenant, your user name should just be your login name (do not include the @ tenant part)


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved