Solved

Error message: Another process has added 'RolesInGraph' record. Your changes will be lost

  • 27 July 2022
  • 3 replies
  • 324 views

Userlevel 3
Badge

When creating a dashboard, the above error message is displayed. What is the reaon for this and how can it be corrected? (2021 R2)

icon

Best answer by Laura02 27 July 2022, 12:05

View original

3 replies

I am also experiencing this issue.  I’m working in the test tenant, so I’m certain no one else has changed the data.  I’ve closed all other windows and browsers and I’ve even signed out, closed the browser and started a new session.  It’s happening specifically when I’m trying to copy a dashboard to create a new one.  It worked once a few days ago, but not since then.  

These are my steps:

  1. Open “base” dashboard and select Copy
  2. Click the + sign to start a new dashboard; add name & owner role
  3. Select Paste
  4. Site map title, workspace and category all populate with the pasted data (as do the access rights)
  5. Change the Site Map Title to a new name
  6. Select Save
  7. Error message appears
  8. Click OK on the error message and the copied data disappears

I’ve tried copying from different source dashboards, used different names, workspaces and categories.  What am I missing?

Thanks,

***UPDATE***  I hadn’t tried copying in the live tenant, and I’m having no issues there at all, and that’s what matters.  Not sure what’s up with the test tenant, but it will be updated soon enough, so I’m ok.

Userlevel 3
Badge

Hello @laura01 @suemackeown13 

I am experiencing the same issue now, and I don’t see the way to save again. After I close the error message the “copied” dashboard is gone. 

Has anyone found the root cause of this issue and the fix?

Thank you

Badge +16

Hello @suemackeown13 ,

I’ve seen the “Another process has added” message before. Usually the message appears when the same record I’m working on was updated by another person while I had the record up and working on it, but before I saved.  Sometimes I am the one updating the record while I also had it open -- because I sometimes have 2 windows, 2 tabs, or even 2 browsers open at the same time.   One tab/screen doesn’t see and immediately update what I’ve changed on a second tab/screen unless I refresh.

Therefore the next step after seeing the above error is to immediately save again. Did you try to save twice? If so we may need more information about the dashboard you are trying to create and at what point the error appears.  Screen shots are always helpful. Use the delay feature of snipping tool to capture the error within the screen as it’s happening, if possible.

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved