Solved

Wrong Parameter Type Error When Testing Carriers/Ship Vias

  • 6 March 2023
  • 4 replies
  • 139 views

Userlevel 3
Badge

Hey everyone, I keep trying to troubleshoot this issue and I’m coming up short. Anyone have any ideas?

Error: SO Error: Carrier Service returned error. USPS:Wrong parameter type.  Send
  Raised At: 3/6/2023 5:48:04 PM Screen: SO.30.20.00    
 Details:

3/6/2023 5:48:04 PM Error:
SO Error: Carrier Service returned error. USPS:Wrong parameter type.

   at PX.Objects.SO.SOShipmentEntry.ShipPackages(SOShipment shiporder)
   at PX.Objects.SO.SOShipmentEntry.PackageDetail.ShipPackages(SOShipment shiporder, Action`1 baseMethod)
   at PX.Objects.SO.SOShipmentEntry.<>c__DisplayClass57_0.b__0()
   at PX.Data.PXLongOperation.<>c__DisplayClass18_0.b__0()

icon

Best answer by manikantad18 7 March 2023, 12:47

View original

4 replies

Userlevel 6
Badge +3

HI @gusl Seems like there might be something off with your credentials or parameters. I’m getting successful connection with the below parameters. Check to see if you have something missing or stands out:

 

Userlevel 3
Badge

HI @gusl Seems like there might be something off with your credentials or parameters. I’m getting successful connection with the below parameters. Check to see if you have something missing or stands out:

 

@estebanperalta54 I’ve actually tried this on a local instance and it works perfectly fine, but one of our clients’ instance is having these parameter issues. Could it be only on the carrier level or do you think this might be a deeper issue? Thank you for your response!

Userlevel 7
Badge +12

hI @gusl Most of the times a parameter error on ship for rates is caused by something on the boxes screen. 

Recommended making sure all the boxes have dimensions, unit of measures and do not have anything in carrier package.

 

 

Other settings that can cause this error:

- a zip-code at the Branch or Warehouse level

- incorrect settings on the Branch and Carrier facility codes

 

Here is the link to the configuration guide for Easy Post if it helps: https://acumatica-builds.s3.amazonaws.com/builds/zip/software/addon/easypost/EasyPost-Configuration-Guide.pdf

There is also a video at this link: 

https://community.acumatica.com/add-ons-and-integrations-66/easypost-integration-5260

Userlevel 3
Badge

@manikantad18 Thank you! that helped. The boxes didn’t have dimensions and hence the parameters were wrong. This makes sense. Thank you so much!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved