Installation/login issue with SignalR

I have installed Acumatica on dozens of laptops running Windows 10 without any issues. I’ve tried installing it on Windows 12 Server and Windows 19 Server and whilst it installs I cannot login to the site.

I’ve tried it with the database on the same server or a different server, running the site on port 80 or 443 using different browsers, but everything ends up generating the same error.

After entering the default username and password (admin, setup), press enter, after a few minutes it errors:



Best answer by Steven Allett 11 November 2022, 05:31

View original

11 replies

Userlevel 4

try to upgrade signal R to 2.1.1 I don’t think this is an Acumatica specific issue

I upgraded to .net core 6, but still no difference. I have a feeling it may be a port that is getting blocked as they are hosted servers. I have no idea what port the websocket is using to connect to SignalR so I can’t get the hosting company to check what ports are being blocked. 

Userlevel 4

Well I would look @ 5000. However if you have code ie 400, 503, 307 or what ever i might be of more help. 

Userlevel 6
Badge +5

Which Acumatica version are you installing?

Hi @rosenjon it’s a re-branded version - we call it 2022.213. Ours are normally about 6 months behind the current Acumatica version.

Userlevel 6
Badge +5

I’m just going to assume you’re on I’m not sure what you mean that it is “rebranded” however.

Do you have .Net Framework 4.8 installed as well as .NET Core 3.1?

Male sure you enable all Windows Server services listed on page 19...


Hi @rosenjon. I’ve installed .net framework 4.8 - have tried runtime and developer. I’ve installed .net core 3.1, and even tried 6. I’ve installed on the we components as per the documentation on page 19 except for the SQL full text search, but I don't think I’ve ever needed that before.

Hi @Steven Allett , we have encountered the same error on one of our installations. Did you manage to find a solution for this issue please ?

Thanks in advance. 

Hi @iseychell87. Unfortunately still haven’t found a solution to it. My guess is it's something in group policy that’s causing the issue, but as I'm trying on a hosted server I have no idea what is set and cannot change that kind if thing, If you find a solution, please let me know though.


Hi @iseychell87 , I finally managed to get our hosting provider to stop the AV scanner and that resolved the issue.

Userlevel 7

Hi @Steven Allett - thank you for sharing your solution with the community!



About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved