Question

Database could not be accessed

  • 9 October 2023
  • 6 replies
  • 165 views

I created an instance based on SalesDemo and published the customization. Then, if you close the site and reopen it, you will get this error "Database could not be accessed". Has anyone encountered this? What can be wrong with customization?

 


6 replies

Userlevel 3
Badge

Hi @VladyslavPoberezhets, have you tried restarting the MS SQL service?

MSSQL Management Studio
SQL Server Configuration Manager
​​​​
​​​​​

 

Hope this helps.

Hi @palbores. Yes, I tried, it doesn't help

Userlevel 3
Badge

Hi @palbores. Yes, I tried, it doesn't help

I found this solved issue with same with yours. Try their solution in this thread.

 

 

@palbores I have seen it and already tried.

Userlevel 4
Badge

Hi,

You could have a look at the connection string in the Web.config file.  The below is a screen shot of the relevant line in one of my customisation projects.

 

 

<add name="ProjectX" providerName="System.Data.SqlClient" connectionString="Data Source=DESKTOP-HPD9MVJ\SQLEXPRESS;Initial Catalog=Schick_20230929;Integrated Security=False;User ID=sa;Password=********" />

 

 

John.

 

Userlevel 7
Badge +9

Hi @palbores Are you using the windows Authentication. If yes, please verify if your account has access to the database permissions.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved