Solved

Record not showing despite being found

  • 25 May 2023
  • 2 replies
  • 45 views

Userlevel 3
Badge

Hello,

I have made a new generic inquiry to help with warehouse staff, the last screen they wanted was to show shipments that have been sitting for more than 24 hours. Easy enough since I added a a calculated column to see how long a shipment has been waiting. See image bellow.

I then made a new filter and added the new condition:

 

However the result I get is this:

 

And there is 1 shipment that is over 24 hours old, and in the bottom left hand corner we can see that Acumatica is finding it, just not showing it.

What is also weird is that if I change the filter query to “Less than” 24 hours, it does show every shipment that is less than 24 hours old! So I dont know why “Greater than” and “Greater than or equal to” is broken.

 

Any advice would be greatly appreciated,

Thank you.

 

icon

Best answer by hkabiri 25 May 2023, 16:06

View original

2 replies

Userlevel 6
Badge +5

@AidenMission As a workaround on your GI Results Grid and for the field with formula , TimeToShip, add a convert to Decimal like =CDec( DateDiff(….) ) and use a field like SOOrder.OrderQty as schema field for it. Check if that helps with the filter of Greater than.

Userlevel 3
Badge

Thank you @hkabiri very much! Doing both steps, adding the CDec() and adding the Schema field to TimeToShip made it work.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved