Solved

PowerBI: credentials failing on OData connection despite successful XML view of OData Generic Inquiries

  • 23 June 2021
  • 9 replies
  • 1226 views

Userlevel 2
Badge

Hello all,

Looking for some OData insight here. The goal: pull a Generic Inquiry through to Power BI.

I have the XML page working great with the "Odata" test URL following the naming convention: http://<application site domain>/odata/<company name>

I assumed that was the “test” that would ensure that I’d be able to connect to an OData endpoint within an Acumatica instance.

However, when I attempt to "Get Data" through Power BI and load in the URL with basic authentication, I have tantalizing visibility to the Inquiries, including the one I want to use, but I'm unable to get past the authentication step in order to finish loading data from the data source.

Perplexingly I can't seem to use my regular credentials using Basic authentication, at any level.

 

Here’s the XML. This loads after prompting for Acumatica credentials.

 

 

However, when I use the same URL and enter the same credentials into “Basic” authentication I’m getting the credentials error:

 

From looking online, I’m curious if this is a specific formatting issue related to the OData feed URL, or maybe a “user rights by screen” setting that needs to be configured differently.

 

Interested to hear what others would do to troubleshoot this.

Thank you!

icon

Best answer by arlinewelty93 24 June 2021, 17:32

View original

9 replies

Userlevel 7
Badge +10

Hi @arlinewelty93,

Make sure to include the tenant name after your user name when you login, ex: user@Tenant… I think this is the issue here.

P.S. that’s one more thing that Velixo handles transparently for you (with Acumatica single sign-on and multi-factor authentication as well - something you can’t do with Power Query) 😉

Userlevel 2
Badge

@Gabriel Michaud That was it! Just like when using Report Designer- got it.

And why am I not surprised that Velixo handles this so nicely?

I tried the solution mentioned, but still no luck. the tenet has two spaces and an apostrophe in it, so I used the type that shows on the login screen to get into Acumatica. Any other ideas?

 

Userlevel 7
Badge +11

Hi @jsparks62 

It might be the apostrophe that is the issue. You could setup a test tenant without an apostrophe and then test against that.

Best,

David EIchner, CPA

Yes, that is the problem. But How do I get around it when the data I need is in the tenet with the apostrophe? Is changing the tenant name an option?

 

Userlevel 7
Badge +11

Yes, you can change the Tenant Name

Best,

David Eichner, CPA

Thanks for the help!

@Gabriel Michaud do you know if Active directory usernames affect this at all or could spaces in tenant affect this at all. We are experiencing the same issue

 

Thank you

Userlevel 7
Badge +10

@mgrovergeiger this won’t work with federated logins using Azure Active Directory or ADFS. You can only use an Acumatica account using basic authentication to login via OData. If you’re using the “old” type of AD integration where you enter domain\username and your AD password on the Acumatica login screen that there’s a possibility that it might work.

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved