Question

How to hide rows with 0 figures in report

  • 17 February 2024
  • 9 replies
  • 106 views

Userlevel 4
Badge

Hello all,

I have been working on a report - AR Aging (AR631000) and I am looking to put up a condition where the report should not display the rows that have 0 figures as highlighted below:

 

How can I apply the condition?

 

Thanks in advance.


9 replies

Userlevel 3
Badge

Hi @Harry , There should be a visible expression on that section of the report:

 

=([@Format]<>'S' And $PrintDoc = True)

 

The $printdoc variable checks if there is a balance on the invoice and it will only show the invoice if there is a balance:
 

 

I have also attached the sales demo AR Aging report if you want to have a look at the setup.

Userlevel 4
Badge

Hi @Harry , There should be a visible expression on that section of the report:

 

=([@Format]<>'S' And $PrintDoc = True)

 

The $printdoc variable checks if there is a balance on the invoice and it will only show the invoice if there is a balance:
 

 

I have also attached the sales demo AR Aging report if you want to have a look at the setup.

Hey @frederickodendaal77 ,

I checked it in the report designer, the same condition has been applied, but still it displays the 0 (null) figure on the row level.
I compare it with your attached report too, everything seems to be same. But still I am attaching the compressed version of the report that I am working with.

Userlevel 6
Badge +6

Hi @Harry , There should be a visible expression on that section of the report:

 

=([@Format]<>'S' And $PrintDoc = True)

 

The $printdoc variable checks if there is a balance on the invoice and it will only show the invoice if there is a balance:
 

 

I have also attached the sales demo AR Aging report if you want to have a look at the setup.

Hey @frederickodendaal77 ,

I checked it in the report designer, the same condition has been applied, but still it displays the 0 (null) figure on the row level.
I compare it with your attached report too, everything seems to be same. But still I am attaching the compressed version of the report that I am working with.

Hi @Harry ,

The documents are grouped by statement cycle and by customer, and they are broken down by aging periods or financial periods, depending on the settings of the statement cycle specified for a customer.  If there’s been activity on the customer during the period specified, whether there’s a balance or not, they will appear on this report.  And that’s typically what most companies want.  For a couple of my companies, I’ve added templates that remove the 0 line items from the report using parameters by only showing items the a greater balance, as well as removing Shopify retail customers that don’t need to run on this report.  You can also add another parameter for items Less than 0 to get the inverse.  It’s much easier than editing the report itself.  
I’ve also noticed you’re using a different field than I am.  I’d suggest if you’re trying to do it at the report level, try using the AR Document Post GL.BalanceAmt as your variable rather than the DocBal as they’re usually grouping document balances to get the final posted GL balance for that posting period.  Eliminating the DocBal may not have the results you’re after.  

Once you set up the template, you can share it and set it as the default for everyone. Hope this helps.

Userlevel 4
Badge

Hey @jamesh ,

Thank you for your suggestion. I have some of the figures in negatives too so I applied the below condition:

But the report still displays 0s. It does display the negative figures correctly but also the 0s. Also when I put the condition only for Greater Than 0 then the report hides the 0 balances correctly.

So now how can I display the negatives too?

 

Thanks a lot once again.

Userlevel 6
Badge +6

Try changing the condition to “Does not equal” zero and remove the second line. 

Userlevel 4
Badge

Try changing the condition to “Does not equal” zero and remove the second line. 

Hello @jamesh 
Already given a try, still it does display 0s

 

Userlevel 6
Badge +6

Do you still have the hard coded filters inside your report?

Userlevel 4
Badge

Do you still have the hard coded filters inside your report?

Hey @jamesh,

It is the same as that it was earlier. Re-attaching the compressed format of the report.

Userlevel 7
Badge

Hi @Harry were you able to find a solution? Thank you!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved