Solved

Improved Trace window is empty when run locally (unlicensed) in Acumatica ERP 23R1

  • 14 December 2023
  • 9 replies
  • 74 views

Userlevel 2
Badge

My local development with Acumatica ERP 23R1 (any version) does not display Trace details

in the improved Trace window when opened on a page via the Tools » Trace option.

It shows No records found.

Has anyone else encountered this issue?

The Improved Trace works fine on our development server, but not under localhost/iis. 

icon

Best answer by jedmunds36 4 January 2024, 19:20

View original

9 replies

Userlevel 7
Badge +4

Hi @jedmunds36,

Can you please share screenshot of the issue?

Did you try enabling logging in SM205070 screen to see if that makes any difference? As the issue is specific to the local instance, try IIS reset or try creating a new App Server Pool in the IIS.

Userlevel 2
Badge

 

Userlevel 2
Badge

snapshot attached.   The SM205070 did not affect the result.

thanks!

 

Userlevel 7
Badge +4

Hi @jedmunds36,

You can try targeting the log for the specific window in by modifying the URL like,

  • <<Instance URL>>/(W(4))/Scripts/Trace/index.html 

Note: where (W(windowNumber))

For example, you have the same Acumatica instance open in two tabs, you can find the window number in the URL. Below screenshot for reference,

 

Please feel free to share the outcome and try the IIS Reset to see if that helps.!

Userlevel 2
Badge

Thank you for the reply and Happy New Year!

 

My URL looks like this locally (not the typical “W(n)” window format).

An IIS Reset does not change the empty observation:

 

http://localhost/AcumaticaERP/Main?ScreenId=SO301000&OrderType=SD&OrderNbr=000124103

 

 

Userlevel 7
Badge +4

Hi @jedmunds36,

Happy New Year.!

You can open the Acumatica instance in more than one browser tab that will add W(n) then you can try to check the logs as suggested in my previous comment.

Userlevel 2
Badge

Thank you for clarifying.

The result unfortunately is still remains empty for an error created by entering a bad CustomerID on the Sales Order page:

 

 

Userlevel 7
Badge +4

Hi @jedmunds36,

Thanks for the update.

At this point, I would suggest you create a new Acumatica with Sales Demo data to test if the logging works.

If it does, then the issue is specific to this instance and we could try to explore other options to troubleshoot the issue. If it doesn’t work, the issue could be with the setup/permission/environment. So we could check those aspects.

Userlevel 2
Badge

Thank you for guiding me in the right direction, Vignesh!

 

The problem was located in our web.config, namely we have a tag as shown below:

    <add key="ProfilerMonitorThreads" value="false" />

If modified to True, then the page Trace details are displayed nicely.

 

Sure appreciate you keeping with me on this topic.

john

 

 

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved