Solved

AP Bill not editable in Balanced status when AP Approval activated

  • 10 August 2022
  • 8 replies
  • 320 views

Userlevel 2
Badge

My client recently began using AP Approvals. Specifically, they added an AP Approval Map to the AP Preferences form under the Approval tab and activated it.  Since doing so, when an AP Bill is entered and saved and taken off hold, it moves to a Balanced status as normal.  However, we’ve noticed that they are no longer able to add new lines to the Bill, change dates or vendor locations, etc….all things that can normally be done for a Balanced AP Bill.

If we deactivate the approval map on AP Preferences, we can go back to the same Bill whose fields were greyed out and no lines could be added or changed or deleted, put it on hold, then take it back off hold, and now all those fields are available for editing again and new lines can be added, etc.

If we reactivate the approval map and do the same thing - put the Bill on hold and then take it off hold again - we are back to the fields being greyed out and no lines changes are allowed.

If it matters, this Bill is not subject to the approval map...in other words, the approval map has a condition of Vendor Class = ‘x’, and this Bill’s vendor’s vendor class is not ‘x’. The “Approval” tab on the AP Bill form is empty for this Bill in its Balanced state.

Can anyone tell me why the fields/lines are no longer editable while Balanced when an approval map is activated?  Is this a bug?

The issue they’re encountering is these Bills are imported.  Because the fields/lines are no longer editable after the Bill is first saved (last step of the IS as usual) and goes into a Balanced state, when importing a multi-line Bill, only the first line imports and the remaining lines show in the IS as processed, but the Bill itself only has the one line in it, which is wrong.

Is there a way around this?

I’ve thought of trying to put the Bill on hold as part of the IS (because the Bill IS editable while on hold, even w approvals activated), but after the first line is imported, I get a message that the “Hold button is disabled”. 

I also tried selecting “Hold Documents on Entry” in Preferences. This solved the issue, the imported Bills included all lines, but now we have a new problem of needing to take all the Bills off hold at once (there are a LOT).  There is no Processing task that allows us to do this.  There IS an option on the Generic Inquiry for the replacement form using the Entry Point tab that allows me to check the box for “Enable Mass Actions on Records”, and I tried selecting that and selecting Mass Actions of “Remove Hold [Processing]” and “Hold [Processing]”.  The actions appear on the AP Bills replacement GI, and I can select one or more Bills and click the button to either put on or take off hold and it processes and shows it completed successfully, but the status doesn’t actually change. I will create a separate issue for that situation, but my reason for mentioning it here is...it’s not a viable solution to “Hold Docs on Entry” and then use this to mass-”unhold” the docs once they’ve all been imported.

Any help would be appreciated!

icon

Best answer by bgreene87 1 September 2022, 18:43

View original

8 replies

Userlevel 2
Badge

EDIT:  I found the article by Irina that explains why the Hold/Remove Hold actions don’t work via GI Entry Point “Enable Mass Actions on Records”...because the record needs to then be saved.  She offers a work around using Business Events that I will try.  Still curious why having Approvals activated causes a Balanced Bill to not be editable though...

Badge +18

There is something weird going on, I agree.

Issue could be with the import, approval map, possibly customizations to the screens or processes, or even roles/access rights.

If Irina’s answer doesn’t solve your issues, please rule out customizations, then post the details of the approval map and the import scenario and we  will further assist you. Thank you.

 

Userlevel 2
Badge

The form has not been customized. And I recreated the scenario in my test instance and it acts the same. My test instance form is also not customized.  I’m signed into my test instance as “admin”, so there should be no permissions issues.

We can rule out the import scenario.  I hand-entered a Bill and get the same behavior, in both their system and my test instance on my laptop.

Here’s the approval map:

 

I confirmed the vendor assigned to the Bill does not have vendor class of “ITAPPRVL”.

Thanks!

Userlevel 6
Badge +2

Try Changing Step, If No Approver Found, to Approve Document.

In Rule, I also changed On Approval to Approve Document.

Badge +18

Good work! 

I am ready to agree this looks like a bug. I tried your same approval map and when I Un-hold bills that have vendors whose vendor class is not in the approval map , my bills become not editable while still on Balanced status.

My version is

Also, we had a previous approval map based on Project that are working normally in the same version, same tenant, same vendors.  It’s something about the table/field being used to route the approvals.

Next step - support ticket with Acumatica.

Badge +18

@DConcannon , I tested your suggestion too and unfortunately, the outcome for my bill was the same.  It was a good idea!

Userlevel 2
Badge

@laura01  - Thanks. Support ticket was created yesterday...it’s still Unassigned. It’s a Low priority at this point, so it’s not a huge deal. They’ve agreed to suspend approvals and go back to the testing stage of setting up these approvals until we get this figured out, this just put an unexpected kink in things!

@DConcannon  - Thanks.  I tested this and unfortunately, it didn’t help.  It sure sounded promising, thanks for offering the suggestion!

Userlevel 2
Badge

Got this reply from Acumatica support:

 

Engineering team reviewed your case and provide update.

Update:

Confirmed it's not a bug and it's system as designed. When approval state is enabled, If status is APPROVED user won't able to change\edit. Only way is to put back transaction to HOLD. Approver needs to approve transaction again.

 

Sample Provide:

Imagine the user that adjusts a Bill in Balanced status adjusts it the way that it moves it in the state that needs approval. I.e. the Bill must be approved if amount > $1000, currently the Bill in Balanced status has amount = $900, and user changes it to $100500.  This action surely needs approval, else user will be able at first register the bill with $900, move it to balanced status, then change amount, and then release, using this gap to ignore approval rules. This would be the security whole.

So user needs to move the Bill to Hold, adjust it and then remove it from Hold. If the system regognizes that approval (still) not required it moves the Bill back to Balanced status; if the system recognizes that approval is required then moves it to Pending Approval.

 

So, what we did was this:

  • turn on “hold documents on entry” so the import could finish adding all lines to the Bill
  • adjust the Bills PL GI to allow mass changes per Irina’s article and added a button to “remove from hold”

It’s one extra step for the client to do the “remove from hold” on the summary Bills GI, but it’s a very do-able workaround for their situation.

 

Thanks all!

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved