Solved

Subreport font does not match designer.

  • 15 March 2023
  • 1 reply
  • 70 views

I have a custom report with a subreport.

Both the main report and the sub report have the same Style Template.

The field in both reports use the same style name, size, and settings.

In this case Courier New, 12px, Bold

 

When the report prints the main report fields are in the expected font but the subreport fields do not print in that font.  Changing the values on the subreport have not affected what font appears or whether or not that font is bold.

 

Is there are override somewhere that is forcing the subreport to print differently than designed?

Does anyone have any suggestions on how to get the two reports to use the same font.

Thank you

Daniel Flacks

Applications Services

Evron Computer Systems Corp.

 

icon

Best answer by BenjaminCrisman 15 March 2023, 18:34

View original

1 reply

Userlevel 7
Badge +4

Hi @DFlacks! For this issue have you made sure that under the Common Settings in the subreport that the option for PDFFontEmbedded = True?

Alternatively, have you tried setting the value in the subreport to a variable, then display that variable on the main report and apply the font setting to that?

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved