Question

Sales Order Inquiry Search Field

  • 22 September 2022
  • 15 replies
  • 86 views

Userlevel 3
Badge

I am creating a GI that combines the SOOrder and SOLine tables.  When I use the SOOrder.OrderNbr field as a parameter, the magnifying glass to search the Order Numbers does not show any of the sales orders.  I am able to type in an Order Number in the parameter and the inquiry works but I would like to have the search functionality work properly.  Is there another table that needs to be added into the GI to make the searching work?

 


15 replies

Userlevel 4
Badge

@Laura Carpenter - Please try by making SOOrder as Parent and SOLine as Child Table.

 

 

Userlevel 6
Badge +3

Hi @Laura Carpenter ! I would recommend to join SOOrder to SOLine using SOOrder as the parent table and SOLine as the child table.

When setting up the GI it is important to think of what kind of data you are trying to extract and start with the larger or header tables first and join to the detail tables from there.

Userlevel 3
Badge

@RohitBhandurge@BenjaminCrisman I did try having the SOOrder as the parent and SOLine as the child and it didn’t change the result in the parameter searching capability. 

Userlevel 6
Badge +3

@Laura Carpenter I just tested this in sales demo data and there is no issue pulling up the orders.
Are you able to access the orders outside of this GI?

This seems strange because I tested it a few different ways and I was able to see all the orders each time

Userlevel 2
Badge

@Laura Carpenter Could we also see your Conditions tab?

Correction - disregard that - I now see where you are having the issue.  Can you export the GI and provide?

Userlevel 4
Badge

@Laura Carpenter - @BenjaminCrisman is correct. I just tested in Sales Demo database as well, and I am able to see the data.

 

Wondering if this could be access issue. Can you please try this effort on another instance?

Userlevel 3
Badge

@BenjaminCrisman In the Sales Order screen, I am able to open the selection tool and see the entire list of sales orders in our system.  Is it best at this point, to submit a support case?

Userlevel 3
Badge

@Andy Smith Attached is the exported GI.

Userlevel 6
Badge +3

@Laura Carpenter I uploaded the GI and it worked for me, so it must either be the user or the data of your instance:

I would try making a new user and logging in to see if that helps, or try to copy/paste this GI into new GI.

You could try to go to System Management > Apply Updates > Reset Cache and then Restart Application
It seems it is not likely related, but you may also want to de-activate any active Restriction Groups just to be sure

Userlevel 2
Badge

Thanks @Laura Carpenter .  Loaded this into my sales demo system and am seeing the same result @RohitBhandurge reported above: 

 

I was going to suggest rebuilding the GI from scratch, but maybe a support case is the better path.

For what it is worth - what is the goal of setting the default SO value in the GI design screen itself?  Not saying you’re wrong to do it, but typically for an order number I want my users to manage that in the GI View mode, either by setting it manually, creating a Shared Filter, etc.  Just curious on the use case.

Userlevel 4
Badge

@Laura Carpenter - I’d give a try to restart the application pool if the user accesses are properly assigned. 

Userlevel 6
Badge +2

@Laura Carpenter - Please try by making SOOrder as Parent and SOLine as Child Table.

 

 

Hi @Laura Carpenter The shared GI is working as expected for me also, As @RohitBhandurge  I changed the Relations with each other and uploaded it here and verify once.

But it is working fine in MY local instance 

 

Userlevel 3
Badge

Thank you all for your assistance.  I used the GI that @manikantad18 provided and that didn’t seem to do the trick.  I logged in as other users and I was unable to use the search in the parameter too.  Is it possible that since we have multiple types of SO orders, that is effecting how this interacts?  We have 4 different types and use them for different purposes and this GI is only targeting one of them.  @Andy Smith I am not looking to use the lookup in the GI configuration, it was easier to show it here rather than confuse the situation with a screenshot of the GI in view mode.  

Userlevel 6
Badge +2

Thank you all for your assistance.  I used the GI that @manikantad18 provided and that didn’t seem to do the trick.  I logged in as other users and I was unable to use the search in the parameter too.  Is it possible that since we have multiple types of SO orders, that is effecting how this interacts?  We have 4 different types and use them for different purposes and this GI is only targeting one of them.  @Andy Smith I am not looking to use the lookup in the GI configuration, it was easier to show it here rather than confuse the situation with a screenshot of the GI in view mode.  

Maybe your account has no proper permission to access order types?, still, you are able to order types from your login, and then create a case with Acumatica.

Thanks

Userlevel 3
Badge

Thanks all for your help.  I ended up submitting a support case.  I’ll let you know what they conclude as the issue.

Reply


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2022  Acumatica, Inc. All rights reserved