Report not pulling correct date range

Userlevel 5

Hi all, having an issue with our Hard Goods Forecast not pulling a correct date range. This is a report which I always struggle with because there’s no apparent GI it’s tied to, and then have to poke around in Report Designer to see what’s up.

Here’s the basic report:

Simple enough. Set the date range to this month, run report:

And it pulls all historical data.

So I go poking in Report Designer and nothing looks amiss (but then again I don’t know what the heck I’m looking for):


I’m thinking maybe it’s the Left joins here?

I’m new to this so I’m not sure where else to look… thank you!


Best answer by swartzfeger 10 May 2023, 20:13

View original

2 replies

Userlevel 7

Thank you for sharing your solution with the community @swartzfeger !

Userlevel 5

I’m going to close this as “solved” (for now). I changed the two left joins to inner, saved to server, refreshed the report and re-ran, and it pulled 0 items. I changed the two joins back to their original state, re-uploaded… and now it’s pulling the correct date range. Don’t know how I fixed it but I’m not complaining. :)


About Acumatica ERP system
Acumatica Cloud ERP provides the best business management solution for transforming your company to thrive in the new digital economy. Built on a future-proof platform with open architecture for rapid integrations, scalability, and ease of use, Acumatica delivers unparalleled value to small and midmarket organizations. Connected Business. Delivered.
© 2008 — 2024  Acumatica, Inc. All rights reserved